POJ Happy 2006

目录

1.题目

2.中文翻译

3.代码(枚举可能不能AC)

1.题目

Happy 2006

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 18657 Accepted: 6521

Description

Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9...are all relatively prime to 2006.

Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order.

Input

The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).

Output

Output the K-th element in a single line.

Sample Input

2006 1
2006 2
2006 3

Sample Output

1
3
5

2.中文翻译

Happy 2006

题目描述

如果大公约数(GCD)为1,则两个正整数被认为是相对素数。例如,1、3、5、7、9……都是2006年的相对素数。

现在,您的工作很简单:对于给定的整数m,当这些元素按升序排序时,找到与m相对素数的第K个元素。

输入

输入包含多个测试用例。对于每个测试用例,它包含两个整数m(1<=m<=1000000),K(1<=K<=100000000)。

输出

在一行中输出第K个元素。

样例输入

2006 1
2006 2
2006 3

样例输出

1
3
5

3.代码(枚举可能不能AC)

#encoding=utf-8
import math

#欧几里得算法求最大公约数
def gcd(a,b):
    if b==0:
        return a
    else:
        return gcd(b,a%b)
primes=[]

while True:
    m,k=map(int,input().split())
    #cnt用来计数:出现一个相互素数记一次数
    cnt = 0
    #nums用来枚举:从1到n
    nums = 0
    while True:
        nums+=1
        if gcd(nums,m)==1:
            cnt +=1
            if cnt==k:
                print(nums)
                break

 

你可能感兴趣的:(python)