POJ 2488 A Knight's Journey(DFS)

A Knight's Journey

Time Limit: 1000MS
Memory Limit: 65536K

Total Submissions: 34633
Accepted: 11815

Description

POJ 2488 A Knight's Journey(DFS)Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3

1 1

2 3

4 3

Sample Output

Scenario #1:

A1



Scenario #2:

impossible



Scenario #3:

A1B3C1A2B4C2A3B1C3A4B2C4

题目简单翻译:

给你一个象棋中的马,一个n*m的棋盘,求是否能从一点出发,走遍整个棋盘,不重复走。如果能,按字典序输出第一个序列。如果不能,则输出“impossible”。

解题思路:

dfs,从一点出发,然而因为要字典序较小的,我们就选择(1,1)为起始点吧。注意延伸的方向,优先向字典序小的方向延伸。

代码:

#include<cstdio>

#include<cstring>

#include<queue>



using namespace std;

int n,m;

int vis[26][26];

int dx[]={-2,-2,-1,-1,1,1,2,2};

int dy[]={-1,1,-2,2,-2,2,-1,1};

int a1[1000],a2[1000];

bool check(int x,int y)

{

    return x>=0&&x<n&&y>=0&&y<m;

}

bool dfs(int x,int y,int depth)

{

    if(depth==m*n)

    {

        for(int i=0;i<depth;i++)

            printf("%c%d",a1[i]+'A',a2[i]+1);

        puts("");

        return true;

    }

    for(int i=0;i<8;i++)

    {

        int curx=x+dx[i];

        int cury=y+dy[i];

        if(check(curx,cury)&&vis[curx][cury]==0)

        {

            a1[depth]=curx;

            a2[depth]=cury;

            vis[curx][cury]=1;

            if(dfs(curx,cury,depth+1)) return true;

            vis[curx][cury]=0;

        }

    }

    return false;

}

int main()

{

    int T;

    scanf("%d",&T);

    int flag=0;

    while(T--)

    {

        if(flag) puts("");

        scanf("%d%d",&m,&n);

        memset(vis,0,sizeof vis);

        vis[0][0]=1;

        a1[0]=0,a2[0]=0;

        printf("Scenario #%d:\n",++flag);

        if(!dfs(0,0,1)) puts("impossible");

    }

    return 0;

}

你可能感兴趣的:(poj)