数据结构 10-排序6 Sort with Swap(0, i)(C语言)

10-排序6 Sort with Swap(0, i)


Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤105) followed by a permutation sequence of {0, 1, ..., N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

 code

# include 

int data[100010];
bool visited[100010];

int travCircle(int s)
{
	int current = data[s];
	int cnt = 1;
	visited[s] = true;
	while (current != s)
	{
		visited[current] = true;
		cnt++;
		current = data[current];
	}
	return cnt;
}

int main(void)
{
	int n;
	scanf("%d", &n);
	
	for (int i = 0; i < n; ++i) visited[i] = false;
	for (int i = 0; i < n; ++i) scanf("%d", &data[i]);

	int ans = 0;
	for (int i = 0; i < n; ++i)
	{
		if (visited[i]) continue;
		int tmp = travCircle(i);
		if (i == 0)
		{
			if (tmp == 1) ans += 0;
			else ans += (tmp - 1);
		}
		else
		{
			if (tmp == 1) ans += 0;
			else ans += (tmp + 1);
		}
	}
	printf("%d\n", ans);
	return 0;
}

你可能感兴趣的:(ZJU数据结构,算法,排序算法,数据结构)