HDU 1698——Just a Hook——————【线段树区间替换、区间求和】

Just a Hook
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit  Status  Practice  HDU 1698

Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length. 

HDU 1698——Just a Hook——————【线段树区间替换、区间求和】


Now Pudge wants to do some operations on the hook. 

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks. 
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows: 

For each cupreous stick, the value is 1. 
For each silver stick, the value is 2. 
For each golden stick, the value is 3. 

Pudge wants to know the total value of the hook after performing the operations. 
You may consider the original hook is made up of cupreous sticks. 
 

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases. 
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations. 
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind. 
 

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example. 
 

Sample Input

1 10 2 1 5 2 5 9 3
 

Sample Output

Case 1: The total value of the hook is 24.
 
解题思路:延迟标记。
 
#include<stdio.h>

#include<algorithm>

#include<string.h>

#define mid (L+R)/2

#define lson rt*2,L,mid

#define rson rt*2+1,mid+1,R

const int maxn=101000;

int sumv[maxn*4];

int col[maxn*4];

void PushUP(int rt){



    sumv[rt]=sumv[rt*2]+sumv[rt*2+1];

}

void PushDown(int rt,int len){



    if(col[rt]){



        col[rt*2]=col[rt];

        col[rt*2+1]=col[rt];

        sumv[rt*2]=col[rt]*(len-len/2);

        sumv[rt*2+1]=col[rt]*(len/2);

        col[rt]=0;

    }

}

void build(int rt,int L,int R){



    col[rt]=0;

    if(L==R){



        sumv[rt]=1;

        return ;

    }

    build(lson);

    build(rson);

    PushUP(rt);

}

void update(int rt,int L,int R,int l_ran,int r_ran,int val){



    if(l_ran<=L&&R<=r_ran){



        sumv[rt]=val*(R-L+1);

        col[rt]=val;

        return ;

    }

    PushDown(rt,R-L+1);

    if(l_ran<=mid){



        update(lson,l_ran,r_ran,val);

    }

    if(r_ran>mid){



        update(rson,l_ran,r_ran,val);

    }

    PushUP(rt);

}

int main(){



    int t,cnt=0;

    scanf("%d",&t);

    while(t--){



        int n,m;

        scanf("%d%d",&n,&m);

        build(1,1,n);

        for(int i=0;i<m;i++){



            int ta,tb,tc;

            scanf("%d%d%d",&ta,&tb,&tc);

            update(1,1,n,ta,tb,tc);

        }

        printf("Case %d: The total value of the hook is %d.\n",++cnt,sumv[1]);

    }

}

  

 

你可能感兴趣的:(HDU)