九度OJ 1468 Sharing -- 哈希

题目地址:http://ac.jobdu.com/problem.php?pid=1468

 

题目描述:

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.
九度OJ 1468 Sharing -- 哈希

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

输入:

For each case, the first line contains two addresses of nodes and a positive N (<= 10^5), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

输出:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

样例输入:
11111 22222 9

67890 i 00002

00010 a 12345

00003 g -1

12345 D 67890

00002 n 00003

22222 B 23456

11111 L 00001

23456 e 67890

00001 o 00010

00001 00002 4

00001 a 10001

10001 s -1

00002 a 10002

10002 t -1
样例输出:
67890

-1
/*

 * Main.c

 *

 *  Created on: 2014年1月20日

 *      Author: Shaobo

 */

#include <stdio.h>

 

#define MAXN 100001

 

typedef struct node{

    char data;

    int next;

}Node;

 

int main(void){

    int first, second, N;

    Node word[MAXN];

    char data;

    int addr, next, i;

    int len1, len2;

    int tfirst, tsecond;

 

    while (scanf ("%d %d %d", &first, &second, &N) != EOF){

        for (i=0; i<N; ++i){

            scanf ("%d %c %d", &addr, &data, &next);

            word[addr].data = data;

            word[addr].next = next;

        }

        len1 = len2 = 0;

        tfirst = first;

        tsecond = second;

        for (i=0; i<N; ++i){           //求得两个单词的长度

            if (tfirst != -1){

                ++len1;

                tfirst = word[tfirst].next;

            }

            if (tsecond != -1){

                ++len2;

                tsecond = word[tsecond].next;

            }

        }

        while (len1 > len2){

            first = word[first].next;

            --len1;

        }

        while (len2 > len1){

            second = word[second].next;

                --len2;

        }

        while (len1 > 0){

            if (first == second){

                printf ("%05d\n", first);

                break;

            }

            else{

                first = word[first].next;

                second = word[second].next;

            }

            --len1;

        }

        if (len1 == 0)

            printf ("-1\n");

    }

    return 0;

}

 


 

你可能感兴趣的:(sha)