CCNP – EIGRP 综合实验
1. Configure all interfaces in the topology diagram with the IP addresses shown. Configure a bandwidth of 64 on all serial interfaces.
2. Configure EIGRP AS 1 to route all networks shown in the diagram. && Disable auto-summarization.
R1:
router eigrp 1
network 172.16.1.1 0.0.0.0
network 172.16.12.1 0.0.0.0
no auto-summary
R2:
router eigrp 1
network 172.16.2.1 0.0.0.0
network 172.16.12.2 0.0.0.0
network 172.16.23.2 0.0.0.0
no auto-summary
R3:
router eigrp 1
network 172.16.0.0
no auto-summary
R4
router eigrp 1
network 172.16.0.0
no auto-summary
3. Configure R4 to summarize its loopback addresses to the most specific summary possible.
172.16.4.00000001
172.16.4.00100001
172.16.4.01000001
172.16.4.01100001
interface Serial1/2
bandwidth 64
ip address 172.16.34.4 255.255.255.0
ip summary-address eigrp 1 172.16.4.0 255.255.255.128 5
serial restart-delay 0
end
4. Do not multicast EIGRP hellos on the network between R1 and R2.
R1:
router eigrp 1
neighbor 172.16.12.2 Serial1/0
R2:
router eigrp 1
neighbor 172.16.12.2 Serial1/0
5. Modify the hello timers on the link between R2 and R3 to send a hello packet every 2 seconds.
R2:
interface Serial1/1
ip hello-interval eigrp 1 2
R3:
interface Serial1/1
ip hello-interval eigrp 1 2
6. Use MD5 authentication with the key "cisco" over the link between R3 and R4.
R3(config)#key chain EIGRP-KEYS
R3(config-keychain)#key 1
R3(config-keychain)#key-string cisco
R3(config-keychain)#end
R3(config)#interface s1/2
R3(config-if)#ip authentication mode eigrp 1 md5
R3(config-if)#ip authentication key-chain eigrp 1 EIGRP-KEYS
R4(config)#key chain EIGRP-KEYS
R4(config-keychain)#key 1
R4(config-keychain)#key-string cisco
R4(config-keychain)#end
R4(config)#interface s1/2
R4(config-if)#ip authentication mode eigrp 1 md5
R4(config-if)#ip authentication key-chain eigrp 1 EIGRP-KEYS
7. Run a Tcl script on all routers to verify that there is connectivity between the correct routers and IP addresses.
R1#tclsh
R1(tcl)#foreach address {
+>(tcl)#172.16.1.1
+>(tcl)#172.16.12.1
+>(tcl)#172.16.12.2
+>(tcl)#172.16.2.1
+>(tcl)#172.16.23.2
+>(tcl)#172.16.23.3
+>(tcl)#172.16.3.1
+>(tcl)#172.16.3.33
+>(tcl)#172.16.3.65
+>(tcl)#172.16.3.97
+>(tcl)#172.16.34.3
+>(tcl)#172.16.34.4
+>(tcl)#172.16.4.1
+>(tcl)#172.16.4.33
+>(tcl)#172.16.4.65
+>(tcl)#172.16.4.97
+>(tcl)#} {
+>(tcl)#ping $address
+>(tcl)#}
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/45/60 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/24/48 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/24/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/19/24 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/36/68 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/35/48 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/36/76 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.65, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/33/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.97, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/32/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.34.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/32/40 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.34.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/56/84 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.4.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/54/68 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.4.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/52/64 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.4.65, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/53/80 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.4.97, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/56/64 ms