2749:分解因数

http://poj.grids.cn/practice/2749/

Description
给出一个正整数a,要求分解成若干个正整数的乘积,即a = a1 * a2 * a3 * ... * an,并且1 < a1 <= a2 <= a3 <= ... <= an,问这样的分解的种数有多少。注意到a = a也是一种分解。
Input
第1行是测试数据的组数n,后面跟着n行输入。每组测试数据占1行,包括一个正整数a (1 < a < 32768)
Output
n行,每行输出对应一个输入。输出应是一个正整数,指明满足要求的分解的种数
Sample Input
2

2

20

Sample Output
1

4

#include <iostream>

#include <cmath>

using namespace std;

int dp(int i,int n)

{

    int sum=1;

    for(;i<=sqrt(n);i++)

    {

        if(n%i==0)

        {

            sum+=dp(i,n/i);

        }

    }

    return sum;

}

int main()

{

    int n,t,ans;

    cin>>t;

    while(t--)

    {

        cin>>n;

        ans=dp(2,n);

        cout<<ans<<endl;

    }

    return 0;

}

 

你可能感兴趣的:(2749:分解因数)