http://poj.org/problem?id=2299
Ultra-QuickSort
Time Limit: 7000MS |
|
Memory Limit: 65536K |
Total Submissions: 40977 |
|
Accepted: 14817 |
Description
In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,
Ultra-QuickSort produces the output
0 1 4 5 9 .
Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input
The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output
For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input
5
9
1
0
5
4
3
1
2
3
0
Sample Output
6
0
题意就是求逆对数。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
__int64 a[5000005],c[5000005];
__int64 k;
void px(int low,int mid,int hight)
{
int i=low,cnt=0,j=mid+1;
while(i<=mid&&j<=hight)
{
if(a[i]>=a[j])
{
c[cnt++]=a[j++];
k+=mid-i+1;
}
else
c[cnt++]=a[i++];
}
while(i<=mid)
{
c[cnt++]=a[i++];
}
while(j<=hight)
{
c[cnt++]=a[j++];
}
i=low;cnt=0;
while(i<=hight)
{
a[i++]=c[cnt++];
}
}
void gb(int low,int hight)
{
int mid=(low+hight)/2;
if(low<hight)
{
gb(low,mid);
gb(mid+1,hight);
px(low,mid,hight);
}
}
int main()
{
int i,n;
while(~scanf("%d",&n)&&n!=0)
{
k=0;
for(i=0;i<n;i++)
scanf("%I64d",&a[i]);
gb(0,n-1);
printf("%I64d\n",k);
}
return 0;
}