学习 BGP与RIP简单路由

BGP 定义:
BGP(Border Gateway Protocol)是一种在自治系统之间动态交换路由信息的路由协议。一个自治系统的经典定义是在一个管理机构控制之下的一组路由器,它使用IGP和普通度量值向其他自治系统转发报文。

 

  在BGP中使用自治系统这个术语是为了强调这样一个事实:一个自治系统的管理对于其他自治系统而言是提供一个统一的内部选路计划,它为那些通过它可以到达的网络提供了一个一致的描述。

 

  BGP,边界网关协议,是自主网络系统中网关之间交换器路由信息的协议。边界网关协议常常应用于互联网的网关之间。路由表包含已知路由器的列表、路由器能够达到的地址以及到达每个路由器的路径的跳数。

 

  使用边界网关协议的主机一般也使用传输控制协议(TCP)。当网络检测到某台主机发出变化时,就会发送新的路由表。BGP-4,边界网关协议的最新版本,允许网络管理员在策略描述下配置跳数的规格。
*************************************************

BGP与RIP简单路由
 

 
------------------------Router0的主要配置:
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router bgp 100
 bgp log-neighbor-changes
 no synchronization
 neighbor 192.168.1.2 remote-as 200
 neighbor 192.168.2.2 remote-as 300
 network 192.168.1.0
 network 192.168.0.0
!
ip classless
!
!
------------------------Router1的主要配置,如下:
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.1.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router bgp 200
 bgp log-neighbor-changes
 no synchronization
 neighbor 192.168.1.1 remote-as 100
 neighbor 192.168.2.2 remote-as 300
 network 192.168.1.0
 network 192.168.2.0
!
ip classless
!
!
!
------------------------Router2的主要配置,如下:
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.3.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.2.2 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router bgp 300
 bgp log-neighbor-changes
 no synchronization
 neighbor 192.168.2.1  remote-as 200
 neighbor 192.168.1.1  remote-as 100
 network 192.168.2.0
 network 192.168.3.0
 network 192.168.4.0
 network 192.168.10.0
!
router rip
 network 192.168.3.0
!
ip classless
!
!
------------------------Router5的主要配置,如下:
!
interface Loopback1
 ip address 192.168.4.1 255.255.255.0
!
interface Loopback2
 ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.3.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 no ip address
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 network 192.168.3.0
 network 192.168.4.0
 network 192.168.10.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.3.1
!
!
-------------------------------------------------------------------
Router0#show ip bgp
BGP table version is 14, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.0.0/24    0.0.0.0                  0     0 32768 i
*> 192.168.1.0/24    0.0.0.0                  0     0 32768 i
*                    192.168.1.2              0     0     0 200 i
*> 192.168.2.0/24    192.168.1.2              0     0     0 200 i
*> 192.168.3.0/24    192.168.1.2              0     0     0 300 200 i
*> 192.168.4.0/24    192.168.1.2              0     0     0 300 200 i
*> 192.168.10.0/24   192.168.1.2              0     0     0 300 200 i

-----------------------------------

思考,OSPF 是否可以导入 BGP中?就像OSPF和RIP可以相互导入一样。

 

 

你可能感兴趣的:(职场,休闲,BGP路由,BGP和RIP,BGP路由表)