RIPv2中的偏移列表的应用









R1#sh run

!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Serial1/2
ip address 12.1.1.1 255.255.255.0
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router rip
version 2
network 1.0.0.0
network 12.0.0.0
no auto-summary
!
!
end

R1#
R1#sh ip route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
23.0.0.0/24 is subnetted, 1 subnets
R 23.1.1.0 [120/1] via 12.1.1.2, 00:00:08, Serial1/2
12.0.0.0/24 is subnetted, 1 subnets
C 12.1.1.0 is directly connected, Serial1/2
R1#


R2#sh run

!
interface Serial1/2
ip address 23.1.1.1 255.255.255.0
serial restart-delay 0
!
interface Serial1/3
ip address 12.1.1.2 255.255.255.0
serial restart-delay 0
!
router rip
version 2
offset-list 1 in 5 Serial1/3
network 12.0.0.0
network 23.0.0.0
no auto-summary
!
!
access-list 1 permit 1.1.1.0 0.0.0.255
!
end

R2#
R2#sh ip route


Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets
R 1.1.1.0 [ 120/6] via 12.1.1.1, 00:00:16, Serial1/3
23.0.0.0/24 is subnetted, 1 subnets
C 23.1.1.0 is directly connected, Serial1/2
12.0.0.0/24 is subnetted, 1 subnets
C 12.1.1.0 is directly connected, Serial1/3


R3#sh run

interface Serial1/3
ip address 23.1.1.2 255.255.255.0
serial restart-delay 0
!
router rip
version 2
network 23.0.0.0
no auto-summary
!
end

 
R3#sh ip route

Gateway of last resort is not set

1.0.0.0/24 is subnetted, 1 subnets
R 1.1.1.0 [ 120/7] via 23.1.1.1, 00:00:02, Serial1/3
23.0.0.0/24 is subnetted, 1 subnets
C 23.1.1.0 is directly connected, Serial1/3
12.0.0.0/24 is subnetted, 1 subnets
R 12.1.1.0 [120/1] via 23.1.1.1, 00:00:02, Serial1/3



你可能感兴趣的:(职场,休闲,offset-list,偏移列表)