一、思科队列技术除了FIFO外,还有:
1、Weight fair queuing(WFQ)
2、Flow-based weighted fair queuing
3、Class-based weighted fair queuing(CBWFQ)
4、Low latency queuing(LLQ)
二、WFQ
1、WFQ在2M以下的链路上(E1)被默认激活,在x.25或compressed ppp上默认为disable。E3或T3以上的局域网链路或串行链路不支持WFQ
2、WFQ分4种类型:flow-based,distributed,class-based,distributed class-based
3、WFQ配置示例(1):
r1(config-if)# fair-queue {congestion-discard-threshold} //拥塞丢弃门限值,可取1-512,默认为64
4、WFQ配置示例(2):
r2(config)#interface serial 1
r2(config-if)# encapsulation frame-relay
r2(config-if)# fair-queue 128
r2(config-if)# bandwidth 56
三、Class-based Weighted Fair Queuing(CBWFQ)
1、接口带宽/类带宽=weight //类带宽越大,权越小,优先级越高
2、配置示例(1):
step1(config)# class-map xxx
step1(config-cmap)# match access-group 101
step1(config-cmap)# match input-interface s0/0
step1(config-cmap)# match protocol tcp
step1(config-cmap)# match ip precedence tos
step2(config)# policy-map yyy
step2(config-pmap)# class xxx
step2(config-pmap-c)# bandwidth 64
step2(config-pmap-c)# queue-limit 128 //尾丢弃
step2(config-pmap-c)# random-detect 128 //WRED,随机早期检测
//默认情况下,class class-default 采用 flow-based WFQ
step3(config)# interface s0/0
step3(config-if)# service-policy output yyy
3、配置示例(2):
router(config)# access-list 101 permit udp host 10.10.10.10 host 10.10.10.20 range 16382 20000 //定义语音流量
router(config)# access-list 102 permit udp host 10.10.10.10 host 10.10.10.20 range 53000 56000 //定义视频流量
router(config)# class-map class1
router(config-cmap)# match access-group 101
router(config-cmap)# exit
router(config)# class-map class2
router(config-cmap)# match access-group 102
router(config-cmap)# exit
router(config)# policy-map policy1
router(config-pmap)# class class1
router(config-pmap-c)# bandwidth 3000 //3M带宽
router(config-pmap-c)# queue-limit 30 //尾丢弃,30个包
router(config-pmap-c)# exit
router(config-pmap)# class class2
router(config-pmap-c)# bandwidth 2000 //默认WFQ,64个包
四、LLQ
router(config)# policy yyy
router(config-pmap)# class xxx
router(config-pmap-c)# priority 30
在定义LLQ时,bandwidth,queue-limit,random-detect命令不能同时使用