EIGRP负载均衡的实验:
一、拓扑如上
二、配置IP地址
r1#show ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.4.1 YES manual up up
Serial1/0 192.168.1.1 YES manual up up
Serial1/1 unassigned YES unset administratively down down
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
r1#
r2#show ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
Serial1/0 192.168.1.2 YES manual up up
Serial1/1 192.168.2.1 YES manual up up
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
Loopback0 2.2.2.2 YES manual up up
r2#
r3#show ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
Serial1/0 unassigned YES unset administratively down down
Serial1/1 192.168.2.2 YES manual up up
Serial1/2 192.168.3.2 YES manual up up
Serial1/3 unassigned YES unset administratively down down
r3#
r4#show ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.4.2 YES manual up up
Serial1/0 unassigned YES unset administratively down down
Serial1/1 unassigned YES unset administratively down down
Serial1/2 192.168.3.1 YES manual up up
Serial1/3 unassigned YES unset administratively down down
Loopback0 4.4.4.4 YES manual up up
r4#
三、配置EIGRP路由协议自治系统1
r1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
r1(config)#router eigrp 1
r1(config-router)#no auto
r1(config-router)#no auto-summary
r1(config-router)#network 192.168.1.0
r1(config-router)#network 192.168.4.0
r1(config-router)#end
r2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
r2(config)#router eigrp 1
r2(config-router)#no auto
r2(config-router)#no auto-summary
r2(config-router)#network 192.168.1.0
r2(config-router)#network 192.168.2.0
00:12:28: %DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 192.168.1.1 (Serial1/0) is up: new adjacency
r2(config-router)#network 192.168.2.0
r2(config-router)#network 2.2.2.0 255.255.255.0
r2(config-router)#end
r3#conf t
Enter configuration commands, one per line. End with CNTL/Z.
r3(config)#router eigrp 1
r3(config-router)#no aut
r3(config-router)#no auto-summary
r3(config-router)#network 192.168.2.0
r3(config-router)#network 192.168.3.0
00:07:49: %DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 192.168.2.1 (Serial1/1) is up: new adjacency
r3(config-router)#network 192.168.3.0
r3(config-router)#end
r3#
r4#conf t
Enter configuration commands, one per line. End with CNTL/Z.
r4(config)#router eigrp 1
r4(config-router)#no aut
r4(config-router)#no auto-summary
r4(config-router)#network 192.168.3.0
r4(config-router)#network 192.168.4.0
r4(config-router)#network 192
00:08:09: %DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 192.168.3.2 (Serial1/2) is up: new adjacency
r4(config-router)#network
00:08:10: %DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 192.168.4.1 (FastEthernet0/0) is up: new adjacency
r4(config-router)#network 4.4.4.0 255.255.255.0
r4(config-router)#end
r4#s
四、实验调试
产看R4上的路由表:
r4#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
2.0.0.0/24 is subnetted, 1 subnets
D 2.2.2.0 [90/2300416] via 192.168.4.1, 00:02:41, FastEthernet0/0
4.0.0.0/24 is subnetted, 1 subnets
C 4.4.4.0 is directly connected, Loopback0
C 192.168.4.0/24 is directly connected, FastEthernet0/0
D 192.168.1.0/24 [90/2172416] via 192.168.4.1, 00:02:41, FastEthernet0/0
D 192.168.2.0/24 [90/2681856] via 192.168.3.2, 00:02:41, Serial1/2
C 192.168.3.0/24 is directly connected, Serial1/2
r4#
路由器R4到达路由器R2的loopback0有两条路径,但是路由器会将FD最小的放入路由表,选择走F0/0接口,通过以上的路由表我们就可以看出来
那么另一条路径是不是可行后继路由呢?在路由器R4上查看托普表如下:
r4#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(4.4.4.4)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 2.2.2.0/24, 1 successors, FD is 2300416
via 192.168.4.1 (2300416/2297856), FastEthernet0/0
via 192.168.3.2 (2809856/2297856), Serial1/2
P 4.4.4.0/24, 1 successors, FD is 128256
via Connected, Loopback0
P 192.168.1.0/24, 1 successors, FD is 2172416
via 192.168.4.1 (2172416/2169856), FastEthernet0/0
P 192.168.2.0/24, 1 successors, FD is 2681856
via 192.168.3.2 (2681856/2169856), Serial1/2
P 192.168.3.0/24, 1 successors, FD is 2169856
via Connected, Serial1/2
P 192.168.4.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/0
r4#
有事出去了,回来接着写......
继续下去.......
从上面的结果我们可以看出,第二条路径的AD(通告距离)为2297856 <(可行距离FD:2300416),
所以第二条路经走s1/2是最有路径f0/0的可行后继
同时EIGRP支持等价负载均衡,和非等价负载均衡.....
【技术要点】
EIGRP 非等价负载均衡是通过“variance”命令实现的, “variance”默认是 1(即代
表等价路径的负载均衡), variance值的范围是1-128.这个参数代表了可以接受的不等价路
径的度量值的倍数,在这个范围内的链路都将被接受,并且被放入路由表中。
本实验做了效果没出来,不知是哪的问题??????
以后纠正,重新做........