EIGRP和RIP的互通

一、配置如下:
 
R1配置:
R1#show run
Building configuration...
Current configuration : 525 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 20.0.0.1 255.0.0.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.0.0.1 255.0.0.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 network 10.0.0.0
 network 20.0.0.0
!
ip classless
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
line vty 0 4
 login
!
!
!
end

R1#
R2配置:
R2#show run
Building configuration...
Current configuration : 638 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 20.0.0.2 255.0.0.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 30.0.0.1 255.0.0.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 10
 redistribute rip metric 200 200 200 200 1500
 network 30.0.0.0
 auto-summary
!
router rip
 redistribute eigrp 10 metric 15
 network 20.0.0.0
!
ip classless
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
line vty 0 4
 login
!
!
!
end

R2#
R3配置:
R3#show run
Building configuration...
Current configuration : 544 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 40.0.0.1 255.0.0.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 30.0.0.2 255.0.0.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 10
 network 30.0.0.0
 network 40.0.0.0
 auto-summary
!
ip classless
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
line vty 0 4
 login
!
!
!
end

R3#
二、验证试验
R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
Gateway of last resort is not set
C    10.0.0.0/8 is directly connected, FastEthernet0/1
C    20.0.0.0/8 is directly connected, FastEthernet0/0
R    30.0.0.0/8 [120/15] via 20.0.0.2, 03:28:59, FastEthernet0/0
R    40.0.0.0/8 [120/15] via 20.0.0.2, 03:28:12, FastEthernet0/0
R1#
说明:R1能够学习到40.0.0.0/8的网络并且显示为一个RIP网络,这是因为R2将EIGRP转换为RIP转换为。
 
PC0上ping PC1
Pinging 30.0.0.1 with 32 bytes of data:
Reply from 30.0.0.1: bytes=32 time=62ms TTL=254
Reply from 30.0.0.1: bytes=32 time=62ms TTL=254
Reply from 30.0.0.1: bytes=32 time=63ms TTL=254
Reply from 30.0.0.1: bytes=32 time=62ms TTL=254
Ping statistics for 30.0.0.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 62ms, Maximum = 63ms, Average = 62ms
说明:整个网络可以通讯。
 

本文出自 “hongguang” 博客,谢绝转载!

你可能感兴趣的:(职场,休闲,rip,EIGRP)