HDU1856

http://acm.hdu.edu.cn/showproblem.php?pid=1856
More is better
Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 2834    Accepted Submission(s): 1062


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.



Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)


Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.



Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8


Sample Output
4
2

Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).

In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 


Author
lxlcrystal@TJU

并查集
参考文章: http://blog.csdn.net/EnjoyInwind/article/details/6206058
#include <stdio.h>

#define MAX 10000000

long pre[MAX];
long num[10000010];
long find(long x)
{
	return pre[x] == x ? x: pre[x] = find(pre[x]);
}

void marge(long a, long b)
{
	long x = find(a);
	long y = find(b);
	if(x != y)
	{
		pre[x] = y;
	}
}

long count ()
{
	long i, max = 0 ;
	for (i = 1 ; i <= 10000000 ; i++) num[i] = 0 ;
	for (i = 1 ; i <= 10000000 ; i++) num[find(i)]++ ;
	for (i = 1 ; i <= 10000000 ; i++) if (num[i] > max) max = num[i] ;
	return max ;
}
int main()
{
	long n, p1, p2, i, max = 0, j, cnt;
	while(scanf("%d", &n) != EOF)
	{
		for(i = 1; i <= MAX; i++)
			pre[i] = i;
		i = 1;
		while(i <= n)
		{
			scanf("%ld%ld", &p1, &p2);
			if(find(p1) != find(p2))
			{
				marge(p1, p2);
			}
			i++;
		}
	
		printf("%ld\n", count());
	}
	return 0;
}

你可能感兴趣的:(HDU)