HDU1003

Max Sum
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 52982    Accepted Submission(s): 11890


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.



Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).



Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.



Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5


Sample Output
Case 1:
14 1 4

Case 2:
7 1 6


Author
Ignatius.L

#include <stdio.h>

#define MAX 100005

int nNum[MAX];
int start, end;

//算法思路:用sum和max来记录临时最大和最终最大,而start end ts te 分别用来记录起点 终点 临时起始点 终点
int cal(int len)
{
	int max, i, sum, ts, te;
	sum = max = -9999; //让max和sum开始置于无限小
	for(i = 0; i < len; i++)
	{
		if(sum < 0)
		{
			if(nNum[i] > sum)
			{
				sum = nNum[i];
				ts = te = i;
				if(max < sum)
				{
					max= sum;
					start = ts;
					end = te;
				}
			}
		}else
		{
			sum += nNum[i];
			te = i;
			if(sum > max)
			{
				max = sum;
				start = ts;
				end = te;
			}
		}
	}
	return max;
}
int main()
{
	int t, i, n, j;
//	freopen("input.in", "r", stdin);
	scanf("%d", &t);
	for(i = 1; i <= t; i++)
	{
		scanf("%d", &n);
		for(j = 0; j < n; j++)
			scanf("%d", &nNum[j]);
		int max = cal(n);
		printf("Case %d:\n", i);
		printf("%d %d %d\n", max, start + 1, end + 1);
		if(i != t)
			printf("\n");
	}
	return 0;
}

你可能感兴趣的:(HDU)