HDU2025

查找最大元素
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11078    Accepted Submission(s): 5998


Problem Description
对于输入的每个字符串,查找其中的最大字母,在该字母后面插入字符串“(max)”。



Input
输入数据包括多个测试实例,每个实例由一行长度不超过100的字符串组成,字符串仅由大小写字母构成。



Output
对于每个测试实例输出一行字符串,输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入"(max)"。



Sample Input
abcdefgfedcba
xxxxx


Sample Output
abcdefg(max)fedcba
x(max)x(max)x(max)x(max)x(max)

#include <stdio.h>
#include <string.h>

char str[105];
//不必对字符串进行处理,只要判断在最大的时候输出即可
int main()
{
	int len, i;
	int max;
	while(scanf("%s", str) != EOF)
	{
		max = 0;
		len = strlen(str);
		for(i = 1; i < len; i++)
		{
			if(str[max] < str[i])
				max = i;
		}

		for(i = 0; i < len; i++)
		{
			if(str[max] == str[i])
			{
				printf("%c(max)", str[i]);
				continue;
			}
			printf("%c", str[i]);
		}
		printf("\n");
	}
	return 0;
}

你可能感兴趣的:(HDU)