rip ospf eigrp 之间相互重分发

实验拓扑图:                                                   
R1  f0/0---------------f0/1 R2
R2  f0/0---------------f0/0 R3
R3  f0/1---------------f0/0 R4
R4  f0/1---------------f0/0 R5



R1

R1#sh run
Building configuration...

Current configuration : 1078 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.255
!        
interface FastEthernet0/0
 ip address 12.1.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 ip address 172.16.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 redistribute rip subnets
 network 10.10.10.10 0.0.0.0 area 1
 network 12.1.1.0 0.0.0.255 area 1
!
router rip
 network 172.16.0.0
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!        
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

R2

R2#sh run
Building configuration...

Current configuration : 850 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 20.20.20.20 255.255.255.255
!        
interface FastEthernet0/0
 ip address 23.1.1.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 12.1.1.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 12.1.1.0 0.0.0.255 area 1
 network 20.20.20.20 0.0.0.0 area 0
 network 23.1.1.0 0.0.0.255 area 0
!
!
!
no ip http server
no ip http secure-server
!
!
!        
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

  R3

R3#sh run
Building configuration...

Current configuration : 850 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 30.30.30.30 255.255.255.255
!        
interface FastEthernet0/0
 ip address 23.1.1.3 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 34.1.1.3 255.255.255.0
 duplex auto
 speed auto
!
router ospf 2
 log-adjacency-changes
 network 23.1.1.0 0.0.0.255 area 0
 network 30.30.30.30 0.0.0.0 area 0
 network 34.1.1.0 0.0.0.255 area 0
!
!
!
no ip http server
no ip http secure-server
!
!
!        
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

R4

R4#sh run
Building configuration...

Current configuration : 850 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 40.40.40.40 255.255.255.255
!        
interface FastEthernet0/0
 ip address 34.1.1.4 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 45.1.1.4 255.255.255.0
 duplex auto
 speed auto
!
router ospf 2
 log-adjacency-changes
 network 34.1.1.0 0.0.0.255 area 0
 network 40.40.40.40 0.0.0.0 area 0
 network 45.1.1.0 0.0.0.255 area 2
!
!
!
no ip http server
no ip http secure-server
!
!
!        
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

  R5

R5#sh run
Building configuration...

Current configuration : 903 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
!        
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 50.50.50.50 255.255.255.255
!        
interface FastEthernet0/0
 ip address 45.1.1.5 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.16.50.5 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 100
 network 172.16.0.0
 auto-summary
!
router ospf 2
 log-adjacency-changes
 redistribute eigrp 100 subnets
 network 45.1.1.0 0.0.0.255 area 2
 network 50.50.50.50 0.0.0.0 area 2
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!        
!
end


R1 sh ip route
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     34.0.0.0/24 is subnetted, 1 subnets
O IA    34.1.1.0 [110/30] via 12.1.1.2, 00:24:01, FastEthernet0/0
     50.0.0.0/32 is subnetted, 1 subnets
O IA    50.50.50.50 [110/41] via 12.1.1.2, 00:24:01, FastEthernet0/0
     20.0.0.0/32 is subnetted, 1 subnets
O IA    20.20.20.20 [110/11] via 12.1.1.2, 00:24:01, FastEthernet0/0
     23.0.0.0/24 is subnetted, 1 subnets
O IA    23.1.1.0 [110/20] via 12.1.1.2, 00:24:01, FastEthernet0/0
     172.16.0.0/24 is subnetted, 2 subnets
O E2    172.16.50.0 [110/20] via 12.1.1.2, 00:21:51, FastEthernet0/0
C       172.16.10.0 is directly connected, FastEthernet0/1
     40.0.0.0/32 is subnetted, 1 subnets
O IA    40.40.40.40 [110/31] via 12.1.1.2, 00:24:01, FastEthernet0/0
     10.0.0.0/32 is subnetted, 1 subnets
C       10.10.10.10 is directly connected, Loopback0
     12.0.0.0/24 is subnetted, 1 subnets
C       12.1.1.0 is directly connected, FastEthernet0/0
     45.0.0.0/24 is subnetted, 1 subnets
O IA    45.1.1.0 [110/40] via 12.1.1.2, 00:24:01, FastEthernet0/0
     30.0.0.0/32 is subnetted, 1 subnets
O IA    30.30.30.30 [110/21] via 12.1.1.2, 00:24:01, FastEthernet0/0

R5 sh ip route
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     34.0.0.0/24 is subnetted, 1 subnets
O IA    34.1.1.0 [110/30] via 12.1.1.2, 00:24:01, FastEthernet0/0
     50.0.0.0/32 is subnetted, 1 subnets
O IA    50.50.50.50 [110/41] via 12.1.1.2, 00:24:01, FastEthernet0/0
     20.0.0.0/32 is subnetted, 1 subnets
O IA    20.20.20.20 [110/11] via 12.1.1.2, 00:24:01, FastEthernet0/0
     23.0.0.0/24 is subnetted, 1 subnets
O IA    23.1.1.0 [110/20] via 12.1.1.2, 00:24:01, FastEthernet0/0
     172.16.0.0/24 is subnetted, 2 subnets
O E2    172.16.50.0 [110/20] via 12.1.1.2, 00:21:51, FastEthernet0/0
C       172.16.10.0 is directly connected, FastEthernet0/1
     40.0.0.0/32 is subnetted, 1 subnets
O IA    40.40.40.40 [110/31] via 12.1.1.2, 00:24:01, FastEthernet0/0
     10.0.0.0/32 is subnetted, 1 subnets
C       10.10.10.10 is directly connected, Loopback0
     12.0.0.0/24 is subnetted, 1 subnets
C       12.1.1.0 is directly connected, FastEthernet0/0
     45.0.0.0/24 is subnetted, 1 subnets
O IA    45.1.1.0 [110/40] via 12.1.1.2, 00:24:01, FastEthernet0/0
     30.0.0.0/32 is subnetted, 1 subnets
O IA    30.30.30.30 [110/21] via 12.1.1.2, 00:24:01, FastEthernet0/0

R1中rip是v1 ,为什么会出现172.16.10.0 的路由?
R5中的eigrp的auto-sum是开启的,宣告的也是主有类,为什么会出现172.16.50.0的路由?

你可能感兴趣的:(职场,休闲,rip,ospf,EIGRP,EIGRP)