控制层面的几种参数:
AD的作用:
1、用来比较路由的优劣,小的放进路由表
METRIC的作用
1、用来比较路由条目的优劣,小的放进路由表
数据层面:
1、DIP与路由条目的掩码做与操作
如果结果与路由前缀相同的
2、最长匹配原则
EIGRP:
1、IGP
2、设计原理,高级DV协议
3、无类协议 classless
4、封装,直接封装在IP协议中,协议字段号88,组播地址为:224.0.0.10
5、收敛很快
6、支持VLSM,CIDR,不连续子网
7、增量更新partial updates
8、支持多种网络层协议
9、组播和单播替代了广播协议
10、支持手动汇总
11、百分百无环
12、支持非等价负载均衡
邻居表:
下一跳路由 接口
拓扑表:
网络前缀 FD/AD
路由表:
网络前缀 最好的路径
FD:可行性距离
到达目的网络的metric
AD:通告距离
邻居到达目标网络的metric
FD小的放进路由表
EIGRP报文
1、hello 用来建立邻居
2、update 更新报文 需要ACK确认
3、query 查询报文 需要ACK确认
4、reply 回复查询报文 需要ACK确认
5、ack 确认可靠报文报文
EIGRP的metric
1、带宽 K1 路径中带宽最小的
2、负载 K2 路径中最大的
3、延迟 K3 路径的总和
4、可靠性 K4 路径中的最小的
5、MTU K5 路径中最小的
默认,带宽和延迟有关
metric=bandwidth+delay
256*(10^7/bw+dly/10)带宽的单位是kbps,延迟us微妙
通过show interface 来查看
实验部分:
1、预配
R1:
interface s1/0
ip address 12.1.1.1 255.255.255.0
no shut
interface lo0
ip address 1.1.1.1 255.255.255.0
no shut
R2:
interface s1/1
clock rate 14400
ip address 12.1.1.2 255.255.255.0
no shut
interface s1/0
clock rate 14400
ip address 23.1.1.2 255.255.255.0
no shut
interface lo0
ip address 2.2.2.2 255.255.255.0
no shut
R3:
interface s1/1
ip address 23.1.1.3 255.255.255.0
no shut
interface lo0
ip address 3.3.3.3 255.255.255.0
no shut
2、配置路由协议
R1:
router eigrp 90 90就是AS号
network 12.1.1.0 0.0.0.255
network 1.1.1.0 0.0.0.255
eigrp router-id 1.1.1.1
R2:
router eigrp 90 这个AS号必须是相同的
network 12.1.1.2 0.0.0.0
network 23.1.1.2 0.0.0.0
network 2.2.2.2 0.0.0.0
eigrp router-id 2.2.2.2
R3:
router eigrp 90
network 23.1.1.0 0.0.0.255
network 3.3.3.0 0.0.0.255
eigrp router-id 3.3.3.3
3、验证配置结果
show ip eigrp interfaces查看哪些接口运行了EIGRP
R3#show ip eigrp interfaces
IP-EIGRP interfaces for process 90
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se1/1 1 0/0 32 0/15 127 0
Lo0 0 0/0 0 0/1 0 0
show ip eigrp neighbors
R3#show ip eigrp neighbors
IP-EIGRP neighbors for process 90
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 23.1.1.2 Se1/1 11 00:25:29 32 200 0 37
H就是说明建立邻居的顺序,如果前面还有一个1的话,说明是刚在0之后建立的一个邻居
address,就是对端邻居的IP地址
interface,是本地对邻居的接口
holdtime,默认是hello时间的3倍
查看hello时间命令:show ip eigrp interface detail s1/0
R1#show ip eigrp interfaces detail s1/0
IP-EIGRP interfaces for process 90
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Se1/0 1 0/0 44 0/24 208 0
Hello interval is 5 sec
Next xmit serial <none>
Un/reliable mcasts: 0/0 Un/reliable ucasts: 35/43
Mcast exceptions: 0 CR packets: 0 ACKs suppressed: 29
Retransmissions sent: 0 Out-of-sequence rcvd: 8
Authentication mode is not set
Use unicast
SRTT,smooth round-trip timer 平滑往返时间,发送报文到收到ack报文的时间,单位毫秒ms
RTO,重传超时计时器,2-16次重传的计时器,经过16次重传后,重置邻居关系,单位毫秒ms
Multicast flow timer:第一次重传是用多播,第一次重传的计时器
建立EIGRP邻居的三个条件:
1、相同的AS号,router eigrp as号
2、相同的K值
3、相同的验证密码
4、不同的RID
EIGRP默认auto-summary,会把本地接口汇总,并指向null0
R3#show ip route eigrp (前提是R1和R2关闭了auto-summary)
1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/2809856] via 23.1.1.2, 00:00:47, Serial1/1
2.0.0.0/24 is subnetted, 1 subnets
D 2.2.2.0 [90/2297856] via 23.1.1.2, 00:00:47, Serial1/1
3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 3.0.0.0/8 is a summary, 00:00:47, Null0
23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 23.0.0.0/8 is a summary, 00:00:47, Null0
12.0.0.0/24 is subnetted, 1 subnets
D 12.1.1.0 [90/2681856] via 23.1.1.2, 00:00:47, Serial1/1
从上面的结果来看,设备只能自动汇总本地直连接口路由,而不能汇总学习到的路由
学习到的路由是对端设备汇总后发送过来的
FD的计算:计算的是路由流向的入接口的带宽和延迟
举例
R1#show ip route eigrp
2.0.0.0/24 is subnetted, 1 subnets
D 2.2.2.0 [90/2297856] via 12.1.1.2, 00:23:27, Serial1/0
D 3.0.0.0/8 [90/2809856] via 12.1.1.2, 00:23:27, Serial1/0
23.0.0.0/24 is subnetted, 1 subnets
D 23.1.1.0 [90/2681856] via 12.1.1.2, 00:23:27, Serial1/0
计算红色的路由条目的FD
1、show interface 路由流向的所有入接口
这里是R1的s1/0,R2的s1/0,R3的lo0
R1#show interfaces s1/0
Serial1/0 is up, line protocol is up
Hardware is M4T
Internet address is 12.1.1.1/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
R2#show interfaces s1/0
Serial1/0 is up, line protocol is up
Hardware is M4T
Internet address is 23.1.1.2/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
R3#show interfaces lo0
Loopback0 is up, line protocol is up
Hardware is Loopback
Internet address is 3.3.3.3/24
MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec,
路径带宽最小值是1544kbps
路径延时总和=20000+20000+5000
metric=256*(10^7/1544+45000/10)=2809856,是一样的吧!
10^7/1544=6476.68不能四舍五入=6476
bandwidth 管理带宽和物理接口带宽无关系
修改带宽,改变FD值
改变R1的s1/0的带宽为1000kbps
R1:
interface s1/0
bandwidth 1000
看看结果
clear ip eigrp neighbor 清除EIGRP邻居关系
R1#show ip route eigrp
2.0.0.0/24 is subnetted, 1 subnets
D 2.2.2.0 [90/3200000] via 12.1.1.2, 00:00:22, Serial1/0
D 3.0.0.0/8 [90/3712000] via 12.1.1.2, 00:00:22, Serial1/0
23.0.0.0/24 is subnetted, 1 subnets
D 23.1.1.0 [90/3584000] via 12.1.1.2, 00:00:22, Serial1/0
通过计算我们还是可以得到上面的值的
metric weights 0 1 1 1 0 0 修改K值,在路由进程下
ip hello-interval eigrp 90 时间 ,在接口模式下修改hello时间,holdtime不会自动修改
ip hold-time eigrp 90 时间 ,修改holdtime
metric={(k1*BW)+((k2*BW)/(256-load))+k3*delay}
if k5!=0
metric=metric*[k5/(reliability+k4)]
然后metric=256*metric