拓扑如上图所示
1.需求:
A.R4模拟intern,R4上有一4.4.4.4的地址;
B.R1访问R4时走R2,但是R1-R2和R2-R4间链路出现问题时,要求R1访问R4走R3
C.全网使用静态路由
2.分析
R2、R3、R4上做全网静态路由
R1上去往4.4.4.4指两条静态路由
iproute 4.4.4.4 255.255.255.255 10.1.12.2
iproute 4.4.4.4 255.255.255.255 10.1.13.3 20---------浮动静态路由(在路由表中不显示
指向R3的静态路由为浮动静态路由,当R1-R2间的链路down时,R1指向R2的静态路由消失,浮动静态路由生效;但是当R2-R4间的链路down时,R1指向R2的静态路由仍然存在,但R1 ping 4.4.4.4不通;因此R1需要一种机制跟踪路由,当某条路由消失的时候,就让ip route 4.4.4.4 255.255.255.255 10.1.12.2这条路由失效。
3.配置
A.各路由器上配置静态路由
R1#
iproute 4.4.4.4 255.255.255.255 10.1.12.2
iproute 4.4.4.4 255.255.255.255 10.1.13.3 20
iproute 10.1.24.0 255.255.255.0 10.1.12.2
iproute 10.1.24.0 255.255.255.0 10.1.13.3 20
R2#
iproute 4.4.4.4 255.255.255.255 10.1.24.4
iproute 10.1.13.0 255.255.255.0 10.1.12.1
iproute 10.1.34.0 255.255.255.0 10.1.24.4
R3#
iproute 4.4.4.4 255.255.255.255 10.1.34.4
iproute 10.1.12.0 255.255.255.0 10.1.13.1
iproute 10.1.24.0 255.255.255.0 10.1.34.4
R4#
iproute 10.1.12.0 255.255.255.0 10.1.24.2
iproute 10.1.12.0 255.255.255.0 10.1.34.3
iproute 10.1.13.0 255.255.255.0 10.1.34.3
B.Track
R1上track路由器R2-R4之间的10.1.24.0这条静态路由,如果这条路由消失(什么情况下会消失?R2-R4间的链路down会引起这条路由消失),那么R1上的静态路由:ip route4.4.4.4 255.255.255.255 10.1.12.2就失效,那么R1上去往4.4.4.4的浮动静态路由:iproute 4.4.4.4 255.255.255.255 10.1.13.3 20就生效了。
具体配置如下:
R1#config terminal
track 1 ip route 10.1.34.0255.255.255.0 reachability
no ip route 4.4.4.4255.255.255.255 10.1.12.2
iproute 4.4.4.4 255.255.255.255 10.1.12.2 track 1
全配置如下:
r1#SH RUN
Building configuration...
Current configuration : 1039 bytes
!
version 12.4
service timestamps debug datetimemsec
service timestamps log datetimemsec
no service password-encryption
!
hostname r1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
track 1 ip route 10.1.34.0255.255.255.0 reachability
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.13.1 255.255.255.0
duplex auto
speed auto
!
ip forward-protocol nd
ip route 4.4.4.4 255.255.255.25510.1.12.2 track 1
ip route 4.4.4.4 255.255.255.25510.1.13.3 20
ip route 10.1.24.0 255.255.255.010.1.12.2
ip route 10.1.24.0 255.255.255.010.1.13.3 20
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
R2#SH RUN
Building configuration...
Current configuration : 936 bytes
!
version 12.4
service timestamps debug datetimemsec
service timestamps log datetimemsec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.12.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.24.2 255.255.255.0
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
ip route 4.4.4.4 255.255.255.25510.1.24.4
ip route 10.1.13.0 255.255.255.010.1.12.1
ip route 10.1.34.0 255.255.255.010.1.24.4
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
R2#
R3#sh run
Building configuration...
Current configuration : 926 bytes
!
version 12.4
service timestamps debug datetimemsec
service timestamps log datetimemsec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.34.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.13.3 255.255.255.0
duplex auto
speed auto
!
ip forward-protocol nd
ip route 4.4.4.4 255.255.255.25510.1.34.4
ip route 10.1.12.0 255.255.255.010.1.13.1
ip route 10.1.24.0 255.255.255.010.1.34.4
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
R4#sh run
Building configuration...
Current configuration : 926 bytes
!
version 12.4
service timestamps debug datetimemsec
service timestamps log datetimemsec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.34.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.24.4 255.255.255.0
duplex auto
speed auto
!
ip forward-protocol nd
ip route 10.1.12.0 255.255.255.010.1.24.2
ip route 10.1.12.0 255.255.255.010.1.34.3
ip route 10.1.13.0 255.255.255.010.1.34.3
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end