CCNP Case


-----------------------------------------------------------------------------------------------------------
Instructions
Configure the routers in the topology according to the diagram and the
specifications below. The T3 and T1 designations are simply labels; you do not
need to change the bandwidth or clockrate on the interfaces to reflect a speed
difference.
-----------------------------------------------------------------------------------------------------------
Requirements
• Configure interfaces with the IP addresses shown in the diagram.
• Add the loopback interface on R3 and the connection between R2 and R3 to
OSPF area 0.
• Add the loopback interfaces on R2 into OSPF area 20. Summarize this area to
the backbone with the most efficient mask.
• Put the connection between R1 and R2 in OSPF area 25. Make this area a totally
NSSA area.
• Redistribute R1’s loopback interface into OSPF.
• Redistribute the T1 and T3 WAN links into OSPF on R3.
• Make sure that all loopback interfaces get advertised with the correct mask into
OSPF.
• Configure R1 and R2 to be in BGP AS 65100. Configure R4 to be in BGP AS
65400.
• Peer R3 and R4 in BGP on both WAN links.
• Advertise R4’s loopback interfaces into BGP.
• Add a static route on R4 to 172.16.0.0/16 pointing to the T3 link to R3. Add a
floating static route as a backup using the T1 link.
• Make AS 65100 prefer the T3 link to AS 65400 networks by modifying the local
preference.
• Configure R2 to act as DHCP server on the 172.16.12.0 network. Make R2 the
default gateway.
---------------------------------------------------------------------------------------------------------
R1#show run
hostname R1
!

interface Loopback0
ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.12.1 255.255.255.0
duplex auto
speed auto
!
router ospf 25
log-adjacency-changes
area 25 nssa
network 172.16.12.0 0.0.0.255 area 25
redistribute connected subnets
!
router bgp 65100
no synchronization
bgp log-neighbor-changes
network 172.16.1.0 mask 255.255.255.0
network 172.16.12.0 mask 255.255.255.0
neighbor 172.16.12.2 remote-as 65100
no auto-summary

#############################################
R2#show run

hostname R2

ip dhcp pool Cisco
   network 172.16.12.0 255.255.255.0
   default-router 172.16.12.2

interface Loopback0
ip address 172.16.123.1 255.255.255.0
!
interface Loopback120
ip address 172.16.120.1 255.255.255.0
!         
interface Loopback121
ip address 172.16.121.1 255.255.255.0
!
interface Loopback122
ip address 172.16.122.1 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.12.2 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0
ip address 172.16.23.2 255.255.255.0
serial restart-delay 0
clock rate 64000
!

router ospf 25
log-adjacency-changes
area 25 nssa
network 172.16.12.0 0.0.0.255 area 25
network 172.16.23.0 0.0.0.255 area 0
network 172.16.120.0 0.0.0.255 area 20
network 172.16.121.0 0.0.0.255 area 20
network 172.16.122.0 0.0.0.255 area 20
network 172.16.123.0 0.0.0.255 area 20
!
router bgp 65100
no synchronization
bgp log-neighbor-changes
network 172.16.12.0 mask 255.255.255.0
network 172.16.23.0 mask 255.255.255.0
network 172.16.120.0 mask 255.255.255.0
network 172.16.121.0 mask 255.255.255.0
network 172.16.122.0 mask 255.255.255.0
network 172.16.123.0 mask 255.255.255.0
neighbor 172.16.12.1 remote-as 65100
neighbor 172.16.23.3 remote-as 65100
no auto-summary

##################################################
R3#show run

hostname R3

interface Loopback0
ip address 172.16.3.1 255.255.255.0
!
interface Serial0/0
ip address 172.16.23.3 255.255.255.0
serial restart-delay 0
!
interface Serial0/1
ip address 192.168.34.3 255.255.255.0
serial restart-delay 0
!
interface Serial0/2
ip address 192.168.43.3 255.255.255.0
serial restart-delay 0
clock rate 64000

router ospf 100
log-adjacency-changes
network 172.16.3.0 0.0.0.255 area 0
network 172.16.23.0 0.0.0.255 area 0
redistribute connected subnets
redistribute bgp 65400 subnets
!
router bgp 65100
no synchronization
bgp log-neighbor-changes
network 172.16.3.0 mask 255.255.255.0
network 172.16.23.0 mask 255.255.255.0
network 192.168.34.0
network 192.168.43.0
neighbor 172.16.23.2 remote-as 65100
neighbor 192.168.43.4 remote-as 65400
neighbor 192.168.43.4 route-map localpref in
redistribute ospf 100 metric 10
no auto-summary

!
access-list 1 permit 192.168.43.0 0.255.255.255

route-map localpref permit 10
   match ip ad 1
   set local-pref 200
route-map localpref permit 20
   set local-pref 100

##################################################
R4#show run

hostname R4
!

interface Loopback212
ip address 172.31.12.1 255.255.255.0
!
interface Loopback200
ip address 172.31.0.1 255.255.255.0
!
interface Loopback208
ip address 172.31.8.1 255.255.255.0
!
interface Loopback2004
ip address 172.31.4.1 255.255.255.0
!
interface Serial0/0
ip address 192.168.34.4 255.255.255.0
serial restart-delay 0
clock rate 64000
!
interface Serial0/1
ip address 192.168.43.4 255.255.255.0
serial restart-delay 0

router bgp 65400
no synchronization
bgp log-neighbor-changes
network 172.31.0.0 mask 255.255.255.0
network 172.31.4.0 mask 255.255.255.0
network 172.31.8.0 mask 255.255.255.0
network 172.31.12.0 mask 255.255.255.0
network 192.168.34.0
network 192.168.43.0
neighbor 192.168.43.3 remote-as 65100
neighbor 192.168.43.3 route-map localpref in
no auto-summary
!
access-list 1 permit 192.168.43.3 0.255.255.255

route-map localpref permit 10
   match ip ad 1
   set local-pref 200
route-map localpref permit 20
   set local-pref 100

ip http server
ip route 172.16.0.0 255.255.0.0 Serial0/1
ip route 172.16.0.0 255.255.0.0 192.168.34.3 100

#######################################################

你可能感兴趣的:(职场,休闲)