EIGRP 非等价负载均衡(2)

 

r1 配置

router>en
router#conf t
router(config)#host r1
r1(config)#no ip domain-lookup
r1(config)#ban mot #Welcome to r1#
r1(config)#ena sec 123
r1(config)#line vty 0 4
r1(config-line)#no login
r1(config-line)#line con 0
r1(config-line)#no exec-time
r1(config-line)#int f 0/0
r1(config-if)#des link to r2
r1(config-if)#ip add 10.1.1.1 255.255.255.0
r1(config-if)#no shut
r1(config-if)#router egirp 1
r1(config-route)#network 10.1.1.0 0.0.0.255
r1(config-route)#end
r1#

r2 配置

router>en
router#conf t
router(config)#host r2
r2(config)#no ip domain-lookup
r2(config)#ban mot #Welcome to r2#
r2(config)#ena sec 123
r2(config)#line vty 0 4
r2(config-line)#no login
r2(config-line)#line con 0
r2(config-line)#no exec-time
r2(config-line)#int f 0/0
r2(config-if)#des link to r1
r2(config-if)#ip add 10.1.1.2 255.255.255.0
r2(config-if)#no shut
r2(config-if)#int s 1/0
r2(config-if)#des link to r4
r2(config-if)#ip add 192.168.2.1 255.255.255.0
r2(config-if)#no shut
r2(config-if)#int f 2/0
r2(config-if)#des link to r3
r2(config-if)#ip add 192.168.1.1 255.255.255.0
r2(config-if)#no shut
r2(config-if)#router eigrp 1
r2(config-route)#network 192.168.1.0 0.0.0.255
r2(config-route)#network 192.168.2.0 0.0.0.255
r2(config-route)#network 10.1.1.0 0.0.0.255
r2(config-route)#end
r2#


r3 配置

router>en
router#conf t
router(config)#host r3
r3(config)#no ip domain-lookup
r3(config)#ban mot #Welcome to r3#
r3(config)#ena sec 123
r3(config)#line vty 0 4
r3(config-line)#no login
r3(config-line)#line con 0
r3(config-line)#no exec-time
r3(config-line)#int f 0/0
r3(config-if)#des link to r2
r3(config-if)#ip add 192.168.1.2 255.255.255.0
r3(config-if)#no shut
r3(config-if)#int s 1/0
r3(config-if)#des link to r4
r3(config-if)#ip add 192.168.3.1 255.255.255.0
r3(config-if)#no shut
r3(config-if)#router eigrp 1
r3(config-route)#network 192.168.1.0 0.0.0.255
r3(config-route)#network 192.168.3.0 0.0.0.255
r3(config-route)#end
r3#


r4 配置

router>en
router#conf t
router(config)#host r4
r4(config)#no ip domain-lookup
r4(config)#ban mot #Welcome to r4#
r4(config)#ena sec 123
r4(config)#line vty 0 4
r4(config-line)#no login
r4(config-line)#line con 0
r4(config-line)#no exec-time
r4(config-line)#int f 0/0
r4(config-if)#des link to r5
r4(config-if)#ip add 172.16.1.1 255.255.255.0
r4(config-if)#no shut
r4(config-if)#int s 1/0
r4(config-if)#des link to r3
r4(config-if)#ip add 192.168.3.2 255.255.255.0
r4(config-if)#clock rate 64000
r4(config-if)#no shut
r4(config-if)#int s 1/1
r4(config-if)#des link to r2
r4(config-if)#ip add 192.168.2.2 255.255.255.0
r4(config-if)#clock rate 64000
r4(config-if)#no shut
r4(config-if)#router eigrp 1
r4(config-route)#network 192.168.2.0 0.0.0.255
r4(config-route)#network 192.168.3.0 0.0.0.255
r4(config-route)#network 172.16.1.0 0.0.0.255
r4(config-route)#end
r4#


r5 配置

router>en
router#conf t
router(config)#host r5
r5(config)#no ip domain-lookup
r5(config)#ban mot #Welcome to r5#
r5(config)#ena sec 123
r5(config)#line vty 0 4
r5(config-line)#no login
r5(config-line)#line con 0
r5(config-line)#no exec-time
r5(config-line)#int f 0/0
r5(config-if)#des link to r4
r5(config-if)#ip add 172.16.1.2 255.255.255.0
r5(config-if)#no shut
r5(config-if)#router egirp 1
r5(config-route)#network 172.16.1.0 0.0.0.255
r5(config-route)#end
r5#

Welcome to r1
r1>en
Password:
r1#show run
Building configuration...

Current configuration : 675 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$GOzQ$WmeHo1BCoOcroXBMYuFC5.
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description link to r2
 ip address 10.1.1.1 255.255.255.0
 duplex half
!
router eigrp 1
 network 10.1.1.0 0.0.0.255
 auto-summary
!
ip classless
no ip http server
!
!
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
banner motd ^CWelcome to r1^C
!
line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 no login
!
!
end

r1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

D    172.16.0.0/16 [90/2174976] via 10.1.1.2, 00:00:45, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0
D    192.168.1.0/24 [90/30720] via 10.1.1.2, 00:03:48, FastEthernet0/0
D    192.168.2.0/24 [90/2172416] via 10.1.1.2, 00:00:50, FastEthernet0/0
D    192.168.3.0/24 [90/2174976] via 10.1.1.2, 00:00:52, FastEthernet0/0
r1#10.1.1.2
Trying 10.1.1.2 ... Open
Welcome to r2
r2>en
Password:
r2#show run
Building configuration...

Current configuration : 1141 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$NeK9$TAKa1lt.Z4eMTlE.vYsCG/
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description link to r1
 ip address 10.1.1.2 255.255.255.0
 duplex half
!
interface Serial1/0
 description link to r4
 ip address 192.168.2.1 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface FastEthernet2/0
 description link to r3
 ip address 192.168.1.1 255.255.255.0
 duplex half
!
router eigrp 1
 network 10.1.1.0 0.0.0.255
 network 192.168.1.0
 network 192.168.2.0
 auto-summary
!
ip classless
no ip http server
!
!
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
banner motd ^CWelcome to r2^C
!
line con 0
 exec-timeout 0 0
 stopbits 1
 line aux 0
 stopbits 1
line vty 0 4
 no login
!
!
end

r2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

D    172.16.0.0/16 [90/2172416] via 192.168.2.2, 00:00:06, Serial1/0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.1.1.0/24 is directly connected, FastEthernet0/0
D       10.0.0.0/8 is a summary, 00:00:04, Null0
C    192.168.1.0/24 is directly connected, FastEthernet2/0
C    192.168.2.0/24 is directly connected, Serial1/0
D    192.168.3.0/24 [90/2681856] via 192.168.2.2, 00:00:01, Serial1/0

r2#192.168.1.2
Trying 192.168.1.2 ... Open
Welcome to r3
r3>en
Password:
r3#show run
Building configuration...

Current configuration : 1013 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r3
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$U26D$0DAVGvXLP.qRqgcuxjpjt1
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description link to r2
 ip address 192.168.1.2 255.255.255.0
 duplex half
!
interface Serial1/0
 description link to r4
 ip address 192.168.3.1 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 1
 network 192.168.1.0
 network 192.168.3.0
 auto-summary
!
ip classless
no ip http server
!
!
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
banner motd ^CWelcome to r3^C
!
line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 no login
!
!
end

r3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

D    172.16.0.0/16 [90/2172416] via 192.168.3.2, 00:00:17, Serial1/0
D    10.0.0.0/8 [90/30720] via 192.168.1.1, 00:00:17, FastEthernet0/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0
D    192.168.2.0/24 [90/2172416] via 192.168.1.1, 00:00:17, FastEthernet0/0
C    192.168.3.0/24 is directly connected, Serial1/0
r3#192.168.3.2
Trying 192.168.3.2 ... Open
Welcome to r4
r4>en
Password:
r4#show run
Building configuration...

Current configuration : 1115 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r4
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$3Nib$Zzf6xJeEzm2PvkWECOsUM0
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description link to r5
 ip address 172.16.1.1 255.255.255.0
 duplex half
!
interface Serial1/0
 description link to r3
 ip address 192.168.3.2 255.255.255.0
 serial restart-delay 0
 clock rate 64000
!
interface Serial1/1
 description link to r2
 ip address 192.168.2.2 255.255.255.0
 serial restart-delay 0
 clock rate 64000
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 1
 network 172.16.1.0 0.0.0.255
 network 192.168.2.0
 network 192.168.3.0
 auto-summary
!
ip classless
no ip http server
!
!
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
banner motd ^CWelcome to r4^C
!
line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
no login
!
!
end

r4#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       172.16.0.0/16 is a summary, 00:01:17, Null0
C       172.16.1.0/24 is directly connected, FastEthernet0/0
D    10.0.0.0/8 [90/2172416] via 192.168.2.1, 00:00:00, Serial1/1
D    192.168.1.0/24 [90/2172416] via 192.168.2.1, 00:00:21, Serial1/1
                    [90/2172416] via 192.168.3.1, 00:00:21, Serial1/0
C    192.168.2.0/24 is directly connected, Serial1/1
C    192.168.3.0/24 is directly connected, Serial1/0

r4#172.16.1.2
Trying 172.16.1.2 ... Open
Wlecom to r5
r5>en
Password:
r5#show run
Building configuration...

Current configuration : 678 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r5
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$vc6Y$cUHIxS99kmRzqklhuyYU21
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description link to r4
 ip address 172.16.1.2 255.255.255.0
 duplex half
!
router eigrp 1
 network 172.16.1.0 0.0.0.255
 auto-summary
!
ip classless
no ip http server
!
!
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
banner motd ^CWlecom to r5^C
!
line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 no login
!
!
end

r5#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
D    10.0.0.0/8 [90/2174976] via 172.16.1.1, 00:00:40, FastEthernet0/0
D    192.168.1.0/24 [90/2174976] via 172.16.1.1, 00:00:40, FastEthernet0/0
D    192.168.2.0/24 [90/2172416] via 172.16.1.1, 00:00:40, FastEthernet0/0
D    192.168.3.0/24 [90/2172416] via 172.16.1.1, 00:00:40, FastEthernet0/0
r5#

更改配置

r4 配置

router>en
router#conf t
router(config)#host r4
r4(config)#no ip domain-lookup
r4(config)#ban mot #Welcome to r4#
r4(config)#ena sec 123
r4(config)#line vty 0 4
r4(config-line)#no login
r4(config-line)#line con 0
r4(config-line)#no exec-time
r4(config-line)#int f 0/0
r4(config-if)#des link to r5
r4(config-if)#ip add 172.16.1.1 255.255.255.0
r4(config-if)#no shut
r4(config-if)#int s 1/0
r4(config-if)#des link to r3
r4(config-if)#ip add 192.168.3.2 255.255.255.0
r4(config-if)#clock rate 64000
r4(config-if)#no shut
r4(config-if)#int s 1/1
r4(config-if)#des link to r2
r4(config-if)#ip add 192.168.2.2 255.255.255.0
r4(config-if)#clock rate 64000
r4(config-if)#no shut
r4(config-if)#router eigrp 1
r4(config-route)#variance 2
r4(config-route)#network 192.168.2.0 0.0.0.255
r4(config-route)#network 192.168.3.0 0.0.0.255
r4(config-route)#network 172.16.1.0 0.0.0.255
r4(config-route)#end
r4#

show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       172.16.0.0/16 is a summary, 00:00:16, Null0
C       172.16.1.0/24 is directly connected, FastEthernet0/0
D    10.0.0.0/8 [90/2172416] via 192.168.2.1, 00:00:16, Serial1/1
                [90/2174976] via 192.168.3.1, 00:00:16, Serial1/0
D    192.168.1.0/24 [90/2172416] via 192.168.2.1, 00:00:16, Serial1/1
                    [90/2172416] via 192.168.3.1, 00:00:16, Serial1/0
C    192.168.2.0/24 is directly connected, Serial1/1
C    192.168.3.0/24 is directly connected, Serial1/0
r4#

本文出自 “一颗平和的心” 博客,转载请与作者联系!

你可能感兴趣的:(负载均衡,职场,休闲,EIGRP)