Configuring Frame Relay DLCI Prioritization

Configuring Frame Relay DLCI Prioritization

Data-link connection identifier (DLCI) prioritization is the process whereby different traffic types are placed upon separate DLCIs so that a Frame Relay network can provide a different committed information rate for each traffic type. It can be used in conjunction with either custom queuing or priority queuing to provide bandwidth management control over the access link to the Frame Relay network. In addition, some Frame Relay service providers and Frame Relay switches (such as the Stratacom Internetwork Packet Exchange [IPX], IGX and BPX or AXIS switches) actually provide prioritization within the Frame Relay cloud based on this priority setting.

Implementation Considerations

When implementing DLCI prioritization, please note the following points:

  • If a secondary DLCI goes down, you lose traffic destined for that queue only.

  • If you lose the primary DLCI, the subinterface goes down and you lose all traffic.

Network Diagram

Configuring Frame Relay DLCI Prioritization_第1张图片

In order to use this setup, you need to have four DLCIs for the side that will use the DLCI prioritization. In this example, we have configured Spicey for priority queueing as follows:

  • Ping is in the high-priority queue.

  • Telnet is in the medium-priority queue.

  • File Transfer Protocol (FTP) is in the normal-priority queue.

  • All other IP traffic is in the low-priority queue.

Note: Make sure you configure the DLCIs to correspond with the priority list, or the system will not use the correct queue.

Configurations

  • Spicey

  • Prasit

Spicey

Spicey#show running-config
Building configuration...

Current configuration : 1955 bytes
!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Spicey
!
!
interface Ethernet0
 ip address 124.124.124.1 255.255.255.0
!
interface Serial0
 no ip address
 encapsulation frame-relay
 priority-group 1
!
interface Serial0.1 point-to-point
 ip address 4.0.1.1 255.255.255.0
 frame-relay priority-dlci-group 1 140 180 190 200
 frame-relay interface-dlci 140   
!
router igrp 2
 network 4.0.0.0
 network 124.0.0.0
!
access-list 102 permit icmp any any
 priority-list 1 protocol ip high list 102
 priority-list 1 protocol ip medium tcp telnet
 priority-list 1 protocol ip normal tcp ftp
 priority-list 1 protocol ip low
!
line con 0
 exec-timeout 0 0
 transport input none
 line aux 0
 line vty 0 4
 login
!
end

Prasit

Prasit#show running-config
Building configuration...

!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Prasit
!
!
!
interface Ethernet0
 ip address 123.123.123.1 255.255.255.0
!
interface Serial1
 ip address 4.0.1.2 255.255.255.0
 encapsulation frame-relay
!
router igrp 2
 network 4.0.0.0
 network 123.0.0.0
!
line con 0
 exec-timeout 0 0
 transport input none
 line aux 0
 line vty 0 4
 login
!
end
debug and show Commands

 

 

 

Use the following show and debug commands to test that your network is operating properly. Before issuing debug commands, please see Important Information on Debug Commands.

  • show frame-relay pvc

  • show frame-relay map

  • show queueing priority

  • debug priority

The output shown below is a result of entering these commands on the devices we are using in this sample configuration.

Spicey

Spicey#show frame-relay pvc
PVC Statistics for interface Serial0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          4            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 140, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0.1

  input pkts 106           output pkts 15           in bytes 6801      
  out bytes 1560           dropped pkts 0           in FECN pkts 0         
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
  in DE pkts 0             out DE pkts 0         
  out bcast pkts 0         out bcast bytes 0         
  pvc create time 00:29:22, last time pvc status changed 00:20:37
  Priority DLCI Group 1, DLCI 140 (HIGH), DLCI 180 (MEDIUM)
  DLCI 190 (NORMAL), DLCI 200 (LOW)

DLCI = 180, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0.1

  input pkts 0             output pkts 51           in bytes 0         
  out bytes 2434           dropped pkts 0           in FECN pkts 0         
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
  in DE pkts 0             out DE pkts 0         
  out bcast pkts 0         out bcast bytes 0         
  pvc create time 00:29:23, last time pvc status changed 00:14:48

DLCI = 190, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0.1

  input pkts 0             output pkts 13           in bytes 0         
  out bytes 3653           dropped pkts 0           in FECN pkts 0         
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
  in DE pkts 0             out DE pkts 0         
  out bcast pkts 13        out bcast bytes 3653      
  pvc create time 00:29:23, last time pvc status changed 00:14:28

DLCI = 200, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0.1

  input pkts 0             output pkts 42           in bytes 0         
  out bytes 2554           dropped pkts 0           in FECN pkts 0         
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
  in DE pkts 0             out DE pkts 0         
  out bcast pkts 10        out bcast bytes 500       
  pvc create time 00:29:24, last time pvc status changed 00:14:09

Spicey#show frame-relay map
Serial0.1 (up): point-to-point dlci, dlci 140(0x8C,0x20C0), broadcast
  status defined, active
  Priority DLCI Group 1, DLCI 140 (HIGH), DLCI 180 (MEDIUM)
  DLCI 190 (NORMAL), DLCI 200 (LOW)

Spicey#show queueing priority
Current priority queue configuration:

List   Queue  Args
1      high   protocol ip          list 102
1      medium protocol ip          tcp port telnet
1      normal protocol ip          tcp port ftp
1      low    protocol ip         

To verify the priority queue, use the debug priority command.

Spicey#debug priority 
Priority output queueing debugging is on

Spicey#ping 123.123.123.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/45/48 ms
Spicey#
*Mar  1 00:32:30.391: PQ: Serial0: ip (s=4.0.1.1, d=123.123.123.1) ->high
*Mar  1 00:32:30.395: PQ: Serial0: ip (s=4.0.1.1, d=123.123.123.1) ->high
*Mar  1 00:32:30.399: PQ: Serial0 output (Pk size/Q 104/0)
*Mar  1 00:32:30.439: PQ: Serial0: ip (s=4.0.1.1, d=123.123.123.1) ->high
*Mar  1 00:32:30.443: PQ: Serial0: ip (s=4.0.1.1, d=123.123.123.1) ->high
*Mar  1 00:32:30.447: PQ: Serial0 output (Pk size/Q 104/0)
*Mar  1 00:32:30.487: PQ: Serial0: ip (s=4.0.1.1, d=123.123.123.1) ->high
*Mar  1 00:32:30.491: PQ: Serial0: ip (s=4.0.1.1, d=123.123.123.1) ->high
*Mar  1 00:32:30.495: PQ: Serial0 output (Pk size/Q 104/0)
*Mar  1 00:32:30.535: PQ: Serial0: ip (s=4.0.1.1, d=123.123.123.1) ->high
*Mar  1 00:32:30.539: PQ: Serial0: ip (s=4.0.1.1, d=123.123.123.1) ->high
*Mar  1 00:32:30.543: PQ: Serial0 output (Pk size/Q 104/0)
*Mar  1 00:32:30.583: PQ: Serial0: ip (s=4.0.1.1, d=123.123.123.1) ->high
*Mar  1 00:32:30.587: PQ: Serial0: ip (s=4.0.1.1, d=123.123.123.1) ->high
*Mar  1 00:32:30.587: PQ: Serial0 output (Pk size/Q 104/0)Spicey#

Spicey#telnet 123.123.123.1
Trying 123.123.123.1 ... Open

User Access Verification

Password: 
*Mar  1 00:32:59.447: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:32:59.451: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:32:59.451: PQ: Serial0 output (Pk size/Q 48/1)
*Mar  1 00:32:59.475: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:32:59.479: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:32:59.483: PQ: Serial0 output (Pk size/Q 44/1)
*Mar  1 00:32:59.487: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:32:59.487: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:32:59.491: PQ: Serial0 output (Pk size/Q 53/1)
*Mar  1 00:32:59.495: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:32:59.499: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:32:59.499: PQ: Serial0 output (Pk size/Q 44/1)
*Mar  1 00:32:59.511: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:32:59.511: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:32:59.515: PQ: Serial0 output (Pk size/Q 47/1)
*Mar  1 00:32:59.519: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:32:59.519: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:32:59.523: PQ: Serial0 output (Pk size/Q 47/1)
*Mar  1 00:32:59.527: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:32:59.527: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:32:59.531: PQ: Serial0 output (Pk size/Q 53/1)
*Mar  1 00:32:59.539: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:32:59.543: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:32:59.547: PQ: Serial0 output (Pk size/Q 47/1)
*Mar  1 00:32:59.751: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:32:59.755: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:32:59.755: PQ: Serial0 output (Pk size/Q 44/1)
Password:

Other IP traffic goes through the low queue.

Spicey#
*Mar  1 00:53:57.079: PQ: Serial0 output (Pk size/Q 13/0)
*Mar  1 00:53:58.851: PQ: Serial0: ip -> low
*Mar  1 00:53:58.907: PQ: Serial0: ip -> low
*Mar  1 00:53:58.907: PQ: Serial0 output (Pk size/Q 36/3)
*Mar  1 00:53:59.459: PQ: Serial0: ip -> low
*Mar  1 00:53:59.463: PQ: Serial0: ip -> low
*Mar  1 00:53:59.463: PQ: Serial0 output (Pk size/Q 50/3)
Spicey#

Prasit

Prasit#show frame-relay pvc

PVC Statistics for interface Serial1 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 150, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1

  input pkts 134           output pkts 119          in bytes 12029     
  out bytes 7801           dropped pkts 0           in FECN pkts 0         
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
  in DE pkts 0             out DE pkts 0         
  out bcast pkts 18         out bcast bytes 1260      
  pvc create time 00:21:15, last time pvc status changed 00:21:15

Prasit#show frame-relay map
Serial1 (up): ip 4.0.1.1 dlci 150(0x96,0x2460), dynamic,
              broadcast, status defined, active

Prasit#ping 124.124.124.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 124.124.124.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/45/48
Here is the debug output shown on Spicey when you use the command above to ping to Spicey from Prasit. 
Spicey#
*Mar  1 00:33:26.755: PQ: Serial0 output (Pk size/Q 13/0)
*Mar  1 00:33:28.535: PQ: Serial0: ip (s=124.124.124.1, d=4.0.1.2) ->high
*Mar  1 00:33:28.539: PQ: Serial0: ip (s=124.124.124.1, d=4.0.1.2) ->high
*Mar  1 00:33:28.543: PQ: Serial0 output (Pk size/Q 104/0)
*Mar  1 00:33:28.583: PQ: Serial0: ip (s=124.124.124.1, d=4.0.1.2) ->high
*Mar  1 00:33:28.587: PQ: Serial0: ip (s=124.124.124.1, d=4.0.1.2) ->high
*Mar  1 00:33:28.587: PQ: Serial0 output (Pk size/Q 104/0)
*Mar  1 00:33:28.631: PQ: Serial0: ip (s=124.124.124.1, d=4.0.1.2) ->high
*Mar  1 00:33:28.635: PQ: Serial0: ip (s=124.124.124.1, d=4.0.1.2) ->high
*Mar  1 00:33:28.635: PQ: Serial0 output (Pk size/Q 104/0)
*Mar  1 00:33:28.679: PQ: Serial0: ip (s=124.124.124.1, d=4.0.1.2) ->high
*Mar  1 00:33:28.683: PQ: Serial0: ip (s=124.124.124.1, d=4.0.1.2) ->high
*Mar  1 00:33:28.683: PQ: Serial0 output (Pk size/Q 104/0)
*Mar  1 00:33:28.723: PQ: Serial0: ip (s=124.124.124.1, d=4.0.1.2) ->high
*Mar  1 00:33:28.727: PQ: Serial0: ip (s=124.124.124.1, d=4.0.1.2) ->high
*Mar  1 00:33:28.731: PQ: Serial0 output (Pk size/Q 104/0)

Prasit#telnet 124.124.124.1
Trying 124.124.124.1 ... Open


User Access Verification
Password: 
Spicey>exit

[Connection to 124.124.124.1 closed by foreign host]
Prasit#

Here is the debug output shown on Spicey when you use the command above to telnet to Spicey from Prasit.

Spicey#
*Mar  1 00:33:54.499: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:54.499: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:54.503: PQ: Serial0 output (Pk size/Q 48/1)
*Mar  1 00:33:54.527: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:54.531: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:54.531: PQ: Serial0 output (Pk size/Q 56/1)
*Mar  1 00:33:54.547: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:54.551: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:54.555: PQ: Serial0 output (Pk size/Q 86/1)
*Mar  1 00:33:54.559: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:54.563: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:54.563: PQ: Serial0 output (Pk size/Q 47/1)
*Mar  1 00:33:54.571: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:54.575: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:54.575: PQ: Serial0 output (Pk size/Q 47/1)
*Mar  1 00:33:54.779: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:54.783: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:54.783: PQ: Serial0 output (Pk size/Q 44/1)
*Mar  1 00:33:56.755: PQ: Serial0 output (Pk size/Q 13/0)
*Mar  1 00:33:57.143: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:57.143: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:57.147: PQ: Serial0 output (Pk size/Q 44/1)
*Mar  1 00:33:57.447: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:57.447: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:57.451: PQ: Serial0 output (Pk size/Q 44/1)
*Mar  1 00:33:57.899: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:57.899: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:57.903: PQ: Serial0 output (Pk size/Q 53/1)
*Mar  1 00:33:59.491: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:59.495: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:59.495: PQ: Serial0 output (Pk size/Q 45/1)
*Mar  1 00:33:59.711: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:59.715: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:59.715: PQ: Serial0 output (Pk size/Q 45/1)
*Mar  1 00:33:59.951: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:59.951: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:33:59.955: PQ: Serial0 output (Pk size/Q 45/1)
*Mar  1 00:34:00.123: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:34:00.123: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:34:00.127: PQ: Serial0 output (Pk size/Q 45/1)
*Mar  1 00:34:00.327: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:34:00.327: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:34:00.331: PQ: Serial0 output (Pk size/Q 46/1)
*Mar  1 00:34:00.495: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:34:00.499: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:34:00.499: PQ: Serial0 output (Pk size/Q 44/1)
*Mar  1 00:34:00.543: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:34:00.543: PQ: Serial0: ip (tcp 23) -> medium
*Mar  1 00:34:00.547: PQ: Serial0 output (Pk size/Q 44/1)

你可能感兴趣的:(Cisco,relay,frame,configuring,DLCI)