PBR基于策略的路由
实验1:基于源IP地址的策略路由
配置概述:
本配置将演示基于源IP地址的报文策略路由。如图13-2所示,路由器1将 1.1.1 .1来的所有数据从接口E1/1发出,而将从1.1.1.2来的所有数据从接口E1/2发出。
图 源地址策略路由
路由器1和2通过交叉电缆连接。1作为DCE为1提供时钟。IP地址的分配如图13-2所示,2定义了一回送(Look back)接口作为测试点。1也定义了几个在loopback0上的二级接口同样作为测试点。路由器1和2配置RIP。在1的loopback接口上应用IP策略route-map语句Lab1,为从 1.1.1 .1来的数据设置下一跳接口为E1/1,为从
1.1.1 .2来的数位设置下一跳接口为E1/2,所有其他的报文将用正常的基于目的地址的路由。
路由器配置:1. 路由器1
R1#sh run
interface Loopback0
ip address 1.1.1 .1 255.255.255.0 secondary
ip address 1.1.1 .2 255.255.255.0 secondary
ip address 1.1.1 .3 255.255.255.0 secondary
ip address 1.1.1 .10 255.255.255.0
ip policy route-map lab1
no keepalive
interface Ethernet1/1
ip address 12.12.12 .1 255.255.255.0
interface Ethernet1/2
ip address 21.21.21 .1 255.255.255.0
router rip
network 12.12.0 .0
network 21.21.0 .0
network 1.1.1 .0
access-list 1 permit 1.1.1 .1
access-list 2 permit 1.1.1 .2
!
route-map lab1 permit 10
match ip address 1
set interface Ethernet1/1
route-map lab1 permit 20
match ip address 2
set interface Ethernet1/2
2. 路由器2
R1#sh run
interface Loopback0
ip address 2.2.2 .2 255.255.255.0
interface Ethernet1/1
ip address 12.12.12 .2 255.255.255.0
interface Ethernet1/2
ip address 21.21.21 .2 255.255.255.0
router rip
network 12.12.0 .0
network 21.21.0 .0
network 2.2.0.0
实验2:基于报文大小的策略路由
配置概述本配置将演示基于报文大小的策略路由。如图13-3所示,路由器1为大小从64~100字节的报文选择发送接口E1/1,而为大小从101~1000字节的报文选择发送接口E1/2。所有其他长度的报文均按正常方式路由。
图13-3 基于报文大小策略路由
1和2用交叉电缆连接,2作为DCE为1提供时钟,IP地址的分配如图13-3所示。路由器2 有一回送接口(IP地址为 2.2.2 .2)作为测试点。路由器1和2都以RIP为它们的路由协议。在1的Loopback接口上应用IP策略route-map语句lab1。这个策略将为64 ~ 100字节大小的报文设置12.12.12.2作为下一转发IP地址,而大小101~ 1000字节的是21.21.21.2。所有其他长度的报文都按基于目的地址的路由方法路由。
路由器配置
下面给出了本例中两台路由器的配置:
1. 路由器1
R1#sh run
interface Loopback0
ip address 1.1.1 .1 255.255.255.0
ip policy route-map lab1
no keepalive
interface Ethernet1/1
ip address 12.12.12 .1 255.255.255.0
interface Ethernet1/2
ip address 21.21.21 .1 255.255.255.0
router rip
network 1.0.0 .0
network 12.0.0 .0
network 21.0.0 .0
!
ip local policy route-map lab1
route-map lab1 permit 10
match length 64 100
set ip next-ho p 12.12.12 .2
route-map lab1 permit 20
match length 101 1000
set ip next-ho p 21.21.21 .2
2. 路由器2
R2#sh run
interface Loopback0
ip address 2.2.2 .2 255.255.255.0
interface Ethernet1/1
ip address 12.12.12 .2 255.255.255.0
interface Ethernet1/2
ip address 21.21.21 .2 255.255.255.0
router rip
network 2.0.0 .0
network 12.0.0 .0
network 21.0.0 .0
实验3:基于应用的策略路由
配置概述
本配置将演示基于应用(如,FTP、WWW)的策略路由。路由器1将从接口E1/1发送所有的Web 数据(端口80),从接口E1/2发送所有的telnet数据(端口23),所有其他类型的报文按正常方式发送。如图13-4所示。
路由器1和2通过以太网线相连。IP地址分配如图13- 4中所示,2有一个回送接口(IP地址为 2.2.2 .2)作为测试点。
在1的Loopback接口应用IP策略route-map语句lab1,为HTTP报文设置下一跳IP地址为 12.12.12 .2,
而为telnet报文设置为 21.21.21 .2。所有其他类型的报文按基于目的地址的路由方法作一般路由。
路由器配置
本例中两台路由器的配置如下:
1. 路由器1
R1#sh run
interface Loopback0
ip address 1.1.1 .1 255.255.255.0
ip policy route-map lab1
no keepalive
interface Ethernet1/1
ip address 12.12.12 .1 255.255.255.0
interface Ethernet1/2
ip address 21.21.21 .1 255.255.255.0
router rip
network 1.0.0 .0
network 12.0.0 .0
network 21.0.0 .0
!
access-list 101 permit tcp any any eq www
access-list 102 permit tcp any any eq telnet
ip local policy route-map lab1
route-map lab1 permit 10
match ip address 101
set ip next-ho p 12.12.12 .2
route-map lab1 permit 20
match ip address 102
set ip next-ho p 21.21.21 .2
2. 路由器2
R2#sh run
interface Loopback0
ip address 2.2.2 .2 255.255.255.0
interface Ethernet1/1
ip address 12.12.12 .2 255.255.255.0
interface Ethernet1/2
ip address 21.21.21 .2 255.255.255.0
router rip
network 2.0.0 .0
network 12.0.0 .0
network 21.0.0 .0