【POJ 3007】 Organize Your Train part II (字符串HASH)

【POJ 3007】 Organize Your Train part II (字符串HASH)


Organize Your Train part II
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7559   Accepted: 2193

Description

RJ Freight, a Japanese railroad company for freight operations has recently constructed exchange lines at Hazawa, Yokohama. The layout of the lines is shown in Figure 1.

【POJ 3007】 Organize Your Train part II (字符串HASH)_第1张图片
Figure 1: Layout of the exchange lines

A freight train consists of 2 to 72 freight cars. There are 26 types of freight cars, which are denoted by 26 lowercase letters from "a" to "z". The cars of the same type are indistinguishable from each other, and each car's direction doesn't matter either. Thus, a string of lowercase letters of length 2 to 72 is sufficient to completely express the configuration of a train.

Upon arrival at the exchange lines, a train is divided into two sub-trains at an arbitrary position (prior to entering the storage lines). Each of the sub-trains may have its direction reversed (using the reversal line). Finally, the two sub-trains are connected in either order to form the final configuration. Note that the reversal operation is optional for each of the sub-trains.

For example, if the arrival configuration is "abcd", the train is split into two sub-trains of either 3:1, 2:2 or 1:3 cars. For each of the splitting, possible final configurations are as follows ("+" indicates final concatenation position):

  [3:1]
    abc+d  cba+d  d+abc  d+cba
  [2:2]
    ab+cd  ab+dc  ba+cd  ba+dc  cd+ab  cd+ba  dc+ab  dc+ba
  [1:3]
    a+bcd  a+dcb  bcd+a  dcb+a

Excluding duplicates, 12 distinct configurations are possible.

Given an arrival configuration, answer the number of distinct configurations which can be constructed using the exchange lines described above.

Input

The entire input looks like the following.

the number of datasets = m
1st dataset 
2nd dataset
 
... 
m-th dataset

Each dataset represents an arriving train, and is a string of 2 to 72 lowercase letters in an input line.

Output

For each dataset, output the number of possible train configurations in a line. No other characters should appear in the output.

Sample Input

4
aa
abba
abcd
abcde

Sample Output

1
6
12
18

Source

Japan 2006 Domestic


暴力枚举分割每个位置然后前后两部分分别逆置和同时逆置然后HASH两种摆放方式 如果是新串就++然后加入HASH表。。STL会TLE 模板大法……还蛮快的这套板子


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <string>
#include <algorithm>
#define ll long long

using namespace std;
const int HASH = 10007;
const int MAXN = 10007;

char str[1555];
char pre[1555],post[1555];

struct HASHMAP
{
    int head[HASH],next[MAXN],sz;
    unsigned ll state[MAXN];

    void init()
    {
        sz = 0;
        memset(head,-1,sizeof(head));
    }

    int Insert(unsigned ll val)
    {
        //cout<<val<<endl;
        int h = val%HASH;
        for(int i = head[h]; ~i; i = next[i])
            if(val == state[i])
                return 0;

        state[sz] = val;
        next[sz] = head[h];
        head[h] = sz++;
        return 1;
    }
}H;

const int SEED = 13331;
unsigned ll S[MAXN];

int Count(char *st,int len)
{
    for(int i = 1; i <= len; ++i) S[i] = S[i-1]*SEED+st[i-1];
    return H.Insert(S[len]);
}

int main()
{
    freopen("../in.in","r",stdin);
   // freopen("../out.out","w",stdout);
    int m,ans;
    scanf("%d",&m);
    while(m--)
    {
        H.init();
        S[0] = 0;
        ans = 0;
        scanf("%s",str);
        int len = strlen(str);
        for(int i = 1; str[i]; ++i)
        {
            strcpy(post,str+i);
            char ch = str[i];
            str[i] = 0;
            strcpy(pre,str);
            str[i] = ch;

            strcpy(pre+i,post);
            ans += Count(pre,len);
            pre[i] = 0;
            strcpy(post+len-i,pre);
            ans += Count(post,len);
            post[len-i] = 0;

//            cout<<pre<<'1'<<post<<endl;
            reverse(post,post+len-i);
            //cout<<pre<<'1'<<post<<endl;
            strcpy(pre+i,post);
            ans += Count(pre,len);
            pre[i] = 0;
            strcpy(post+len-i,pre);
            ans += Count(post,len);
            post[len-i] = 0;

            //cout<<pre<<'2'<<post<<endl;
            reverse(pre,pre+i);
            //cout<<pre<<'2'<<post<<endl;
            strcpy(pre+i,post);
            ans += Count(pre,len);
            pre[i] = 0;
            strcpy(post+len-i,pre);
            ans += Count(post,len);
            post[len-i] = 0;

            //cout<<pre<<'3'<<post<<endl;
            reverse(post,post+len-i);
            //cout<<pre<<'3'<<post<<endl;
            strcpy(pre+i,post);
            ans += Count(pre,len);
            pre[i] = 0;
            strcpy(post+len-i,pre);
            ans += Count(post,len);
            post[len-i] = 0;
            //cout<<pre<<'4'<<post<<endl;
        }
        printf("%d\n",ans);
    }
    return 0;
}



你可能感兴趣的:(【POJ 3007】 Organize Your Train part II (字符串HASH))