hdu1003 MaxSum (DP)

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 180281    Accepted Submission(s): 42103


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
   
   
   
   
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
   
   
   
   
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1087  1069  2084  1058  1159 
 


#include <stdio.h>
#define num 100000
int main()
{
	int n,t,i,j,flag,a[num],star,q,g;
	long sum,maxsum;
	scanf("%d",&t);
	for(i=1;i<=t;i++)
	{
		    scanf("%d",&n);
			for(j=0;j<n;j++)
				scanf("%d",&a[j]);
			maxsum=a[0];
			sum=0;
			q=flag=0;
			j=star=0;
			for(q=0;q<n;q++)
			{
				if(sum<0)
					sum=a[q],j=q;
				else
					sum=sum+a[q];
				if(sum>maxsum)
				{
					maxsum=sum;
					flag=q;
					star=j;
				}
			}
			printf("Case %d:\n",i);
			printf("%ld %d %d",maxsum,star+1,flag+1);
			if(i==t)
				printf("\n");
			else 
				printf("\n\n");
		
	}
	return 0;

}


你可能感兴趣的:(HDU,HDU1003,1003,MaxSum)