hdu1060 Leftmost Digit

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14951    Accepted Submission(s): 5774


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
   
   
   
   
2 3 4
 

Sample Output
   
   
   
   
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1061  1071  1573  1066  1005 
 

Statistic |  Submit |  Discuss |  Note

说实话 这道题我不会做、、当我看到n的范围那么大 就想着会不会有规律。可n又太大。不知道怎么办 

就百度了

m=n^n,两边同时取对数log10,变为log10(m)=n*log10(n);继续化简为m=10^(n*log10(n)),因为10的任意整数次方

首位都是1,于是首位就和n*log10(n)的小数部分有关了。

还有这样的方法对于2来说是不对的。。不

#include <stdio.h>
#include <math.h>
int main()
{
	int ncase;
	double n,ans;
	scanf("%d",&ncase);
	while(ncase--)
	{
		scanf("%lf",&n);
		ans=log10(n);
		ans=(ans-(int)ans)*n;
		ans=ans-(int)ans;
		printf("%d\n",(int)pow(10,ans));
	}
	return 0;
}



你可能感兴趣的:(HDU,1060,hdu1060)