hdu1004 Let the Balloon Rise(二维字符串数组排序)

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 88886    Accepted Submission(s): 33639


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
   
   
   
   
5 green red blue red red 3 pink orange pink 0
 

Sample Output
   
   
   
   
red pink
 

Author
WU, Jiazhi
 

Source
ZJCPC2004
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1008  1005  1013  1012  1006 
 

Statistic |  Submit |  Discuss |  Note

题目的意思就是找到单词重复次数最多的那个并输出。

起初以为知道都有那几种颜色,那样就把颜色存在一个二维字符串数组里面,输入一次比较一次,对应的sum(n)++。

后来一看没有说,就只能先对字符串排序,然后判断。由于只会结构体的字符串排序。。就这样吧。用结构体存字符串...

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct node
{
	char color[20];
}c[1005];
bool cmp(node a,node b)//比较函数
{
	return strcmp(a.color,b.color)<0;
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0)
		break;
		memset(&c,0,sizeof(&c));
		for(int i=0;i<n;i++)
		scanf("%s",c[i].color);
		sort(c,c+n,cmp);
		int sum=0,max=-1,mark;
		for(int i=0;i<n;i++)
		{
			if(strcmp(c[i].color,c[i+1].color)==0)
			sum++;
			else
			{
				if(sum>max)
				max=sum,mark=i;
				sum=0;
			}
		}
		printf("%s\n",c[mark].color);
	}
	return 0;
}


你可能感兴趣的:(HDU,1004,HDU1004)