hdu2122 Ice_cream’s world III(MST)

Ice_cream’s world III

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1250    Accepted Submission(s): 413


Problem Description
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.
 

Input
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
 

Output
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
 

Sample Input
   
   
   
   
2 1 0 1 10 4 0
 

Sample Output
   
   
   
   
10 impossible
 

Author
Wiskey
 

Source
HDU 2007-10 Programming Contest_WarmUp
 

Recommend
威士忌   |   We have carefully selected several similar problems for you:   2121  2119  2129  2118  2117 
 

Statistic |  Submit |  Discuss |  Note

最小生成树 kruskal算法

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct node
{
	int a,b,cost;
}c[10005];
int fa[1005];
void init(int n)
{
	for(int i=0;i<n;i++)
	fa[i]=i;
}
bool cmp(node x,node y)
{
	return x.cost<y.cost;
}
int find(int x)
{
	if(fa[x]!=x) fa[x]=find(fa[x]);
	return fa[x];
}
int main()
{
	int n,k;
	while(~scanf("%d %d",&n,&k))
	{
		init(n);
		for(int i=0;i<k;i++)
		scanf("%d %d %d",&c[i].a,&c[i].b,&c[i].cost);
		sort(c,c+k,cmp);
		int sum=0;
		for(int i=0;i<k;i++)
		{
			int x=find(c[i].a);
			int y=find(c[i].b);
			if(x!=y)
			sum+=c[i].cost,fa[x]=y;
		}
		int count=0;
		for(int i=0;i<n;i++)
		if(fa[i]==i)
		count++;
		if(count!=1)
		printf("impossible\n\n");
		else
		printf("%d\n\n",sum);
	}
	return 0;
}


你可能感兴趣的:(HDU,kruskal,MST,2122,hdu2122)