九度OnlineJudge之1003:A+B

题目描述:
给定两个整数A和B,其表示形式是:从个位开始,每三位数用逗号","隔开。
现在请计算A+B的结果,并以正常形式输出。

输入:
输入包含多组数据数据,每组数据占一行,由两个整数A和B组成(-10^9 < A,B < 10^9)。

输出:
请计算A+B的结果,并以正常形式输出,每组数据占一行。

样例输入:
-234,567,890 123,456,789
1,234 2,345,678
样例输出:
      -111111101
       2346912
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;




int main()
{
string A,B,T;
int A1,B1;
string::iterator it;

while(cin>>A>>B)
{
 T.clear();
 for(it=A.begin();it!=A.end();it++)
 if(*it!=',') T.push_back(*it);
 A1 = atoi(T.c_str()); 
 T.clear();
 for(it=B.begin();it!=B.end();it++)
 if(*it!=',') T.push_back(*it);
 B1 = atoi(T.c_str()); 
 cout<<A1+B1<<endl;
      
}




  //system("pause");
	return 0;
}

你可能感兴趣的:(九度机试题)