Alisha’s Party
Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value
v , and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.
Each time when Alisha opens the door, she can decide to let
p people enter her castle. If there are less than
p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.
If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query
n Please tell Alisha who the
n−th person to enter her castle is.
Input
The first line of the input gives the number of test cases,
T , where
1≤T≤15 .
In each test case, the first line contains three numbers
k,m and
q separated by blanks.
k is the number of her friends invited where
1≤k≤150,000 . The door would open m times before all Alisha’s friends arrive where
0≤m≤k . Alisha will have
q queries where
1≤q≤100 .
The
i−th of the following
k lines gives a string
Bi , which consists of no more than
200 English characters, and an integer
vi ,
1≤vi≤108 , separated by a blank.
Bi is the name of the
i−th person coming to Alisha’s party and Bi brings a gift of value
vi .
Each of the following
m lines contains two integers
t(1≤t≤k) and
p(0≤p≤k) separated by a blank. The door will open right after the
t−th person arrives, and Alisha will let
p friends enter her castle.
The last line of each test case will contain
q numbers
n1,...,nq separated by a space, which means Alisha wants to know who are the
n1−th,...,nq−th friends to enter her castle.
Note: there will be at most two test cases containing
n>10000 .
Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.
Sample Input
1
5 2 3
Sorey 3
Rose 3
Maltran 3
Lailah 5
Mikleo 6
1 1
4 2
1 2 3
Sample Output
这题。。。头都大了!
#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
struct Ss{
int v,id;
Ss(int v=0,int id=0):v(v),id(id){};//自定义函数
bool operator < (const Ss& u)const{//优先队列排列遵循的规则
if(v!=u.v) return v<u.v;
return id>u.id;
}
};
int l[150002],c[150002],f[150002];
char name[150002][202];
int main()
{
int T,k,m,q,a,b;
scanf("%d",&T);
while(T--){
//初始化
int x,xx=0;
memset(l,0,sizeof(l));
memset(c,0,sizeof(c));
memset(f,0,sizeof(f));
priority_queue <Ss>que;
scanf("%d%d%d",&k,&m,&q);
for(int i=1;i<=k;i++)//用f数组保存礼物的价值
scanf("%s%d",name[i],&f[i]);
//用c数组保存到第几个人的时候让多少人进
for(int i=0;i<m;i++){
scanf("%d%d",&a,&b);
c[a]=b;
}
for(int i=1;i<=k;i++){
que.push(Ss(f[i],i));
int n=c[i];
//用l数组保存第几个进来的人的id
while(!que.empty()&&n){
l[++xx]=que.top().id;
que.pop();
n--;
}
}
//剩下的人要让他们全部进来
while(!que.empty()){
l[++xx]=que.top().id;
que.pop();
}
for(int i=0;i<q;i++){
scanf("%d",&x);
printf("%s",name[l[x]]);
if(i!=q-1) printf(" ");
else printf("\n");
}
}
return 0;
}