hdu 1712 ACboy needs your help(分组背包入门题)

ACboy needs your help

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 842    Accepted Submission(s): 419


Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
 

Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
 

Sample Input
   
   
   
   
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
 

Sample Output
   
   
   
   
3 4 6
 

Source
HDU 2007-Spring Programming Contest
 

Recommend
lcy
 
题目: http://acm.hdu.edu.cn/showproblem.php?pid=1712
分析:这题是裸的分组背包,分组背包最重要的地方就是保证每组里面的物品不同时取,这个可以通过改变枚举物品顺序做到,分三重枚举,第一重枚举第几组,第二重枚举背包容量,要倒着来,第三重枚举该组里面的物品。。。详细请看背包九讲
代码:
#include<cstdio>
#include<iostream>
using namespace std;
const int mm=111;
int f[mm],a[mm][mm];
int i,j,k,n,m;
int main()
{
    while(scanf("%d%d",&n,&m),n+m)
    {
        for(i=0;i<=m;++i)f[i]=0;
        for(i=0;i<n;++i)
            for(j=1;j<=m;++j)scanf("%d",&a[i][j]);
        for(i=0;i<n;++i)
            for(j=m;j>=0;--j)
                for(k=1;k<=j;++k)
                    f[j]=max(f[j],f[j-k]+a[i][k]);
        printf("%d\n",f[m]);
    }
    return 0;
}


你可能感兴趣的:(input,each,Matrix,output)