00-自测2. 素数对猜想 (20)

题目链接: http://www.patest.cn/contests/mooc-ds/00-%E8%87%AA%E6%B5%8B2


00-自测2. 素数对猜想 (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

让我们定义 dn 为:dn = pn+1 - pn,其中 pi 是第i个素数。显然有 d1=1 且对于n>1有 dn 是偶数。“素数对猜想”认为“存在无穷多对相邻且差为2的素数”。

现给定任意正整数N (< 105),请计算不超过N的满足猜想的素数对的个数。

输入格式:每个测试输入包含1个测试用例,给出正整数N。

输出格式:每个测试用例的输出占一行,不超过N的满足猜想的素数对的个数。

输入样例:
20
输出样例:
4

#include <stdio.h>
int IsPrime(int n) {					//判断素数 
	for(int i = 2; i <= sqrt(n); ++i)
		if(n % i == 0)
			return 0;
	return 1;
}
int main() {
	int n;
	scanf("%d", &n);
	int lastPrime = 3, thisPrime = 5;
	int cnt = 0;
	while(thisPrime <= n) {
		if(thisPrime - lastPrime == 2)		//前后两个素数是否间隔2 
			++cnt;
		lastPrime = thisPrime;	
		while(!IsPrime(++thisPrime));		//寻找下一个素数 
	}
	printf("%d", cnt);
	
	return 0;
} 


你可能感兴趣的:(数据结构,C语言,pat,MOOC)