01-复杂度2. Maximum Subsequence Sum (25)

题目链接:http://www.patest.cn/contests/mooc-ds/01-%E5%A4%8D%E6%9D%82%E5%BA%A62

01-2. Maximum Subsequence Sum (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

#include <stdio.h>
#define MAX 100000
int main() {
	int k;
	scanf("%d", &k);
	int data[MAX];
	for(int i = 0; i < k; ++i)
		scanf("%d", &data[i]);
	int thisSum = 0, maxSum = 0;
	int min = 0, max = 0, thisMin = 0;	//min:最大子序列首元素下标;thisMin当前计算的子序列首元素下标 
	int hasZero = 0, zeroIndex = 0;	//区分全部元素是负数 和 有0其他全是负数两种情况下标输出的不同 
	for(int i = 0; i < k; ++i) {
		thisSum += data[i];
		if(!hasZero && data[i] == 0) {	//标记有无0以及0的下标 
			hasZero = 1;
			zeroIndex = i;	
		}
		if(thisSum > maxSum) {	//如果当前计算的子序列大于最大子序列和,更新新的最大子序列相关信息 
			min = thisMin;
			max = i;
			maxSum = thisSum;
		}
		else if(thisSum < 0) {	//如果当前子序列小于0,舍弃 
			thisMin = i + 1;
			thisSum = 0;
		}
	}
	if(maxSum == 0) {//全是负数时输出整个数列第一个元素和最后一个元素的下标 
		if(hasZero)		//有0且其它全是负数时输出0的下标 
			min = max = zeroIndex;
		else
			max = k - 1;
	}
	printf("%d %d %d", maxSum, data[min], data[max]);
	
	return 0;
}


你可能感兴趣的:(数据结构,C语言,MOOC,浙大PAT)