ACM-MST(最小生成树)之Agri-Net——poj1258

*******************************************转载请注明出处: http://blog.csdn.net/lttree**********************************************

Agri-Net
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 37130   Accepted: 14997

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

题目:http://poj.org/problem?id=1258


这道题,赤裸裸的求最小生成树,数组都给你了。

一般给了二维数组,就想用Prim算法做了。。。。

恩,关于Prim的详细东东,不想多说了

(Prim and Kruskal 详情可戳:http://blog.csdn.net/lttree/article/details/26942391 )


直接上代码吧,赤裸裸的MST啊,木有拐弯。。


/****************************************
*****************************************
*        Author:Tree                    *
*From :http://blog.csdn.net/lttree      *
* Title : Agri-Net                      *
*Source: poj 1258                       *
* Hint  : 最小生成树(MST-Prim)       *
*****************************************
****************************************/

#include <stdio.h>

#define RANGE 101
#define MAX 0x7fffffff

int cost[RANGE][RANGE];
int mincost[RANGE];
bool used[RANGE];
int n;

int Min(int a,int b)
{
    return a<b?a:b;
}

void prim( void )
{
    int i,u,v,sum;

    // 以第一个点为起点,初始化mincost和used
    sum=0;
    for( i=1;i<=n;++i )
    {
        used[i]=false;
        mincost[i]=cost[1][i];
    }

    while( true )
    {
        v=-1;
        for( u=1;u<=n;++u )
            if( !used[u] && (v==-1 || mincost[u]<mincost[v]) )
                v=u;
        // 没有可到达的点,则退出
        if( v==-1 ) break;

        used[v]=true;
        sum+=mincost[v];

        for( u=1;u<=n;++u )
            mincost[u]=Min( mincost[u],cost[v][u] );
    }

    // 输出
    printf("%d\n",sum);
}

int main()
{
    int i,j;
    while( scanf("%d",&n)!=EOF )
    {
        for(i=1;i<=n;++i)
            for(j=1;j<=n;++j)
                scanf("%d",&cost[i][j]);
        prim();
    }
    return 0;
}


你可能感兴趣的:(ACM,Prim,Agri-Net,poj1258,MST最小生成树)