FatMouse' Trade
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 14 Accepted Submission(s) : 3
Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
Sample Output
13.333
31.500
首先求出每个房间里单位重量的猫粮能够换多少javabean,假设为c[i],然后对c[i]排序,取c[i]大的数据,这样就能保证换取的javabean最多。
AC代码如下:
#include<stdio.h>
int main()
{
int i,m,n,a[1000],b[1000],k,s,j;
double c[1000],sum,t;
while(scanf("%d %d",&m,&n)!=EOF)
{
if(m==-1&&n==-1) break; /*结束*/
for(i=0;i<n;i++)
{
scanf("%d %d",&a[i],&b[i]);
c[i]=(double)a[i]/b[i]; /*整型换成double型*/
}
for(i=0;i<n;i++)
for(j=i+1;j<n;j++)
if(c[i]>c[j])
{
t=c[i];
c[i]=c[j];
c[j]=t;
k=b[i];
b[i]=b[j];
b[j]=k;
s=a[i];
a[i]=a[j];
a[j]=s;
} /*对c[i]排序,排序的同时a[i],b[i]也要跟着变变下标*/
sum=0.0;
for(i=n-1;i>=0;i--)
{
if(b[i]<m)
sum=sum+a[i]; /*全部换成a[i]*/
else
sum+=m*c[i]; /*换一部分*/
m=m-b[i]; /*m减小*/
if(m<=0) break; /*猫粮用完,跳出循环*/
}
printf("%.3lf\n",sum);
}
return 0;
}