POJ 3104 Drying(二分搜索,最大化最小值)

Drying
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 11464   Accepted: 2967

Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than kwater, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2


题意:有n件衣服,每件衣服的含水量为ai单位,每分钟他们能自然脱水1单位,有一个脱水机,每次只能对一件衣服脱水,脱水量为k单位(脱水时不自然风干),问所有衣服全部风干的最小时间是多少?


题解:首先能够想到的是可以二分查找全部自然风干的最少时间mid。但这一题不同的是在判断函数中用蛮力法判断mid是否满足条件是会出错。需要特殊处理。


设某次二分出的一个值是mid:
1、对于一件ai值小于等于mid的衣服,直接晾干即可;
2、对于一件ai值大于mid值的衣服,最少的用时是用机器一段时间,晾干一段时间,设这两段时间分别是x1和x2,那么有mid=x1+x2,ai<=k*x1+x2,解得x1>=(ai-mid)/(k-1) ,所以对(ai-mid)/(k-1)向上取整就是该件衣服的最少用时。


具体代码如下:


#include<cstdio>
#include<cmath>
#include<cstring>
long long  n,k;
long long a[100010];

bool dix(long long x)
{
	long long i,time=0;
	if(k==1)//注意判断k是否为1,为1在下面会除以0,提交会RE 
		return true;
	for(i=0;i<n;++i)
	{
		if(a[i]>x)
			time+=(a[i]-x+k-2)/(k-1);//用向上取整函数ceil会WA,这里用K-2来向上取整 
	}
	if(time>x)
		return true;
	return false;
}

int main()
{
	long long max;
	long long i;
	while(scanf("%lld",&n)!=EOF)
	{
		max=0;
		for(i=0;i<n;++i)
		{
			scanf("%lld",&a[i]);
			if(max<a[i])
				max=a[i];
		}
		scanf("%lld",&k);
		long long left=0,right=max,mid;
		while(left<right-1)
		{
			mid=(left+right)/2;
			if(dix(mid))
				left=mid;
			else 
				right=mid;	
		}
		printf("%lld\n",right);
	}
	return 0;
}
 






你可能感兴趣的:(POJ 3104 Drying(二分搜索,最大化最小值))