hdoj How Many Equations Can You Find【DFS】

How Many Equations Can You Find

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 709    Accepted Submission(s): 462


Problem Description
Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.
 

Input
Each case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.
 

Output
The output contains one line for each data set : the number of ways you can find to make the equation.
 

Sample Input
   
   
   
   
123456789 3 21 1
 

Sample Output
   
   
   
   
18 1
 

Author
dandelion
 

Source
HDU 8th Programming Contest Online 

用递归枚举所有情况,若满足条件,数目+1,最后输出即可

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
__int64 n;
int num,m,len;
char s[15];
void dfs(int x,__int64 ans)
{
	if(x==len)
	{
		if(ans == n)
			num++;
		return ;
	}
	__int64 a = 0;
	for(int i = x; i < len; i++)
	{
		a = a*10+s[i]-'0';
		dfs(i+1, a+ans);
		if(x!=0)
		dfs(i+1, ans-a);
	}
} 
int main()
{
	while(~scanf("%s",s))
	{
		scanf("%I64d",&n);
		len = strlen(s);
		num = 0;
		dfs(0,0);
		printf("%d\n",num);
	}
	return 0;
}




你可能感兴趣的:(hdoj How Many Equations Can You Find【DFS】)