ACM-栈之Train Problem I——hdu1022

Train Problem I
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18202 Accepted Submission(s): 6819

Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

Sample Input
3 123 321
3 123 312

Sample Output
Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".


这道题是一道栈的练习题,
题意就是一些火车要进站出站,先进后出,后进先出,
进站顺序要按照第一个序列进行
出站顺序必须要按照第二个序列进行
判断这些火车能否照两个序列进行

比如,两个序列为   1234  2134
1进去,2进去,2出来,1出来,3进去,3出来,4进去,4出来——可以完成
序列: 1234  3124
1 进去 2进去 3进去 3出来 1上面有2,无法先让1出来——不可以完成

栈的用法和队列其实很相似

#include <iostream>
#include <string>
#include <stack>
using namespace std;

string str1,str2;
bool isin[1001];
int n,jl;

int stck(void)
{
	stack <char> s;
	int i,j;
	i=j=jl=0;
	
	// 防止栈空,先压进去一个
	isin[jl++]=1;
	s.push(str1[i++]);
	while(i<=n && j<=n)
	{
		// 如果栈空了 或者 栈头元素与第二串相应字符相同,则记录进出,弹出栈头,第二串向后移
		if(s.size() && s.top()==str2[j])
		{
			isin[jl++]=0;
			s.pop();
			++j;
		}
		//否则 将第一串相应元素压进栈
		else
		{
			if(i==n)	break;
			isin[jl++]=1;
			s.push(str1[i++]);
		}
	}
	
	return s.size();
}

int main()
{
	int k;
	while(cin>>n>>str1>>str2)
	{	
		if(stck()==0)
		{
			cout<<"Yes.\n";
			for(k=0;k<2*n;++k)
			{
				if(isin[k])	cout<<"in\n";
				else	cout<<"out\n";
			}
		}
		else	
			cout<<"No.\n";

		cout<<"FINISH\n";
	}
	return 0;
}



你可能感兴趣的:(栈,ACM,problem,I,train,hdu1022)