LC-Display POJ1102

LC-Display
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 12641   Accepted: 4970

Description

A friend of you has just bought a new computer. Until now, the most powerful computer he ever used has been a pocket calculator. Now, looking at his new computer, he is a bit disappointed, because he liked the LC-display of his calculator so much. So you decide to write a program that displays numbers in an LC-display-like style on his computer.

Input

The input contains several lines, one for each number to be displayed. Each line contains two integers s, n (1 <= s <= 10, 0 <= n <= 99 999 999), where n is the number to be displayed and s is the size in which it shall be displayed. 

The input file will be terminated by a line containing two zeros. This line should not be processed.

Output

Output the numbers given in the input file in an LC-display-style using s "-" signs for the horizontal segments and s "|" signs for the vertical ones. Each digit occupies exactly s+2 columns and 2s+3 rows. (Be sure to fill all the white space occupied by the digits with blanks, also for the last digit.) There has to be exactly one column of blanks between two digits. 

Output a blank line after each number. (You will find a sample of each digit in the sample output.)

Sample Input

2 12345
3 67890
0 0

Sample Output

LC-Display POJ1102_第1张图片


题意:以LCD形式显示0-9十个数字,有字体大小的要求。

分析以最小的字符数组number[5][3]存储0-9数字,对于大小s只需重复几次 ‘-’ 和重复几行‘|’。 


源代码如下:

#include <iostream>
#include <string>
using namespace std;

int s,len;
char no[10];

char number[10][5][3]={ {' ','-',' ','|',' ','|',' ',' ',' ','|',' ','|',' ','-',' '},		// 0
			{' ',' ',' ',' ',' ','|',' ',' ',' ',' ',' ','|',' ',' ',' '},		// 1
			{' ','-',' ',' ',' ','|',' ','-',' ','|',' ',' ',' ','-',' '},		// 2
			{' ','-',' ',' ',' ','|',' ','-',' ',' ',' ','|',' ','-',' '},		// 3
			{' ',' ',' ','|',' ','|',' ','-',' ',' ',' ','|',' ',' ',' '},		// 4
			{' ','-',' ','|',' ',' ',' ','-',' ',' ',' ','|',' ','-',' '},		// 5
			{' ','-',' ','|',' ',' ',' ','-',' ','|',' ','|',' ','-',' '},		// 6
			{' ','-',' ',' ',' ','|',' ',' ',' ',' ',' ','|',' ',' ',' '},		// 7
			{' ','-',' ','|',' ','|',' ','-',' ','|',' ','|',' ','-',' '},		// 8
			{' ','-',' ','|',' ','|',' ','-',' ',' ',' ','|',' ','-',' '},		// 9
};

void displayHorizontal(int rowNum)
{
	int i,p,num;
	for(i=0;i<len;i++)			// 第一行
	{
		num=no[i]-'0';
		cout<<" ";
		for(p=0;p<s;p++)
		{
			cout<<number[num][rowNum][1];
		}
		cout<<"  ";
	}
	cout<<endl;
}

void displayVertical(int rowNum)
{
	int i,j,p,num;
	for(p=0;p<s;p++)		//第二行
	{
		for(i=0;i<len;i++)
		{
			num=no[i]-'0';
			cout<<number[num][rowNum][0];
			for(j=0;j<s;j++)cout<<" ";
			cout<<number[num][rowNum][2];
			cout<<" ";
		}
		cout<<endl;
	}
}

int main()
{
	freopen("in.txt","r",stdin);

	while(1)
	{
		cin>>s>>no;
		if(s==0)break;
	
		len=strlen(no);
	
		displayHorizontal(0);
		displayVertical(1);
		displayHorizontal(2);
		displayVertical(3);
		displayHorizontal(4);

		cout<<endl;
	}
		return 0;
}

你可能感兴趣的:(LC-Display POJ1102)