A very hard mathematic problem
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2268 Accepted Submission(s): 683
Problem Description
Haoren is very good at solving mathematic problems. Today he is working a problem like this:
Find three positive integers X, Y and Z (X < Y, Z > 1) that holds
X^Z + Y^Z + XYZ = K
where K is another given integer.
Here the operator “^” means power, e.g., 2^3 = 2 * 2 * 2.
Finding a solution is quite easy to Haoren. Now he wants to challenge more: What’s the total number of different solutions?
Surprisingly, he is unable to solve this one. It seems that it’s really a very hard mathematic problem.
Now, it’s your turn.
Input
There are multiple test cases.
For each case, there is only one integer K (0 < K < 2^31) in a line.
K = 0 implies the end of input.
Output
Output the total number of solutions in a line for each test case.
Sample Input
Sample Output
1
1
0
Hint
9 = 1^2 + 2^2 + 1 * 2 * 2 53 = 2^3 + 3^3 + 2 * 3 * 3
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
int x,y,z,k,ans;
while(cin>>k,k)
{
ans=0;
for(z=2;z<31;z++)
{
y=(int)(pow((double)k,1.0/z));//求解k开n次方
for(x=1;x<y;)
{
__int64 temp=x*y*z+(__int64)(pow((double)x,(double)z)+pow((double)y,(double)z)+0.5);
if(temp>k)
y--;
else if(temp<k)
x++;
else
{x++;y--;ans++;}
}
}
printf("%d\n",ans);
}
return 520;
}