Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 25657 |
|
Accepted: 8532 |
Description
Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall.
Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements.
The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.
Input
The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle.
Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.
Output
Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.
Sample Input
9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200
Sample Output
1628
Hint
结果四舍五入就可以了
Source
Northeastern Europe 2001
总结:这是一个比较基础的计算几何题目,我是先去凸包然后计算周长最后加上一个圆的周长,用笔画一画就出来了。
开始我用C++提交“
F:\temp\11634925.159169\Main.cpp(93) : error C3861: 'round': identifier not found”编译错误。
用G++就AC了。在此贴个网址,水平序法求凸包精度很好。http://www.cnblogs.com/ACMan/archive/2012/09/01/2666646.html
#include <iostream>
#include <cmath>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <vector>
#define next(i) ((i+1)%n)
using namespace std;
//1113 Accepted 784K 63MS G++ 2442B 2013-05-25 21:20:55
const double pi = acos(-1.0);
const double eps = 1e-8;
int dcmp(double x) {
if(fabs(x) < eps) return 0;
if(x > 0) return 1;
return -1;
}
struct point {
double x, y;
point() {}
point(double a, double b) : x(a), y(b) {}
friend point operator - (const point a, const point b) {
return point(a.x-b.x, a.y-b.y);
}
};
double det(const point &a, const point &b) {
return a.x * b.y - a.y * b.x;
}
bool comp_less(const point &a, const point &b) {
return dcmp(a.x-b.x)<0 || (dcmp(a.x-b.x)==0 && dcmp(a.y-b.y)<0);
}
bool cmp(point &a, point &b) {
if(a.x==b.x && a.y==b.y) return true;
else return false;
}
double dist(const point &a, const point &b) {
return sqrt((a.x-b.x)*(a.x-b.x) + (a.y-b.y)*(a.y-b.y));
}
struct polygon_convex {
vector <point> P;
polygon_convex(int Size = 0) {
P.resize(Size);
}
};
polygon_convex convex_hull(vector<point> a) {
polygon_convex res(2*a.size()+5);
sort(a.begin(), a.end(), comp_less);
///a.erase(unique(a.begin(), a.end()), a.end());
a.erase(unique(a.begin(), a.end(), cmp), a.end());
int m = 0;
for(int i = 0; i < (int)a.size(); ++i) {
while(m > 1 && dcmp(det(res.P[m-1]-res.P[m-2], a[i]-res.P[m-2]))<=0)
--m;
res.P[m++] = a[i];
}
int k = m;
for(int i = int(a.size())-2; i >= 0; --i) {
while(m > k && dcmp(det(res.P[m-1]-res.P[m-2], a[i]-res.P[m-2]))<=0)
--m;
res.P[m++] = a[i];
}
res.P.resize(m);
if(a.size()>1) res.P.resize(m-1);
return res;
}
int main()
{
int n, r;
point tmp;
vector <point> v;
while(scanf("%d%d", &n, &r) != EOF) {
v.clear();
for(int i = 0; i < n; i++) {
scanf("%lf%lf", &tmp.x, &tmp.y);
v.push_back(tmp);
}
polygon_convex result = convex_hull(v);
int len = result.P.size();
double res = 0.0;
for(int i = 0; i < len; i++) {
res = res + dist(result.P[i], result.P[(i+1)%len]);
}
double diameter = 2.0 * pi * r;
res += diameter;
int last = round(res);
printf("%d\n", last);
}
return 0;
}