1090. Highest Price in Supply Chain (25)

题目链接:http://www.patest.cn/contests/pat-a-practise/1090
题目:

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence they are numbered from 0 to N-1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. Sroot for the root supplier is defined to be -1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010.

Sample Input:
9 1.80 1.00
1 5 4 4 -1 4 5 3 6
Sample Output:
1.85 2

分析:
这里不知道为什么
Node* shops = new Node[n];后
就一定要shops[i].level,而不是shops[i]->level
怎么申请一个对象数组的指针?(important)

AC代码:
#include<stdio.h>
#include<iostream>
#include<vector>
using namespace std;
int n;
class Node{
public:
 int parent;
 vector<int>sons;
 int level;
 Node(){}
}shops[100002];
void calcLevel(int idx,int curLevel){
 shops[idx].level = curLevel;
 if (shops[idx].sons.size() != 0){
  for (int i = 0; i < shops[idx].sons.size(); i++){
   calcLevel(shops[idx].sons[i], curLevel + 1);
  }
 }
}
int main(){
 freopen("F://Temp/input.txt", "r", stdin);
 double price0, rate;
 cin >> n;
 cin >> price0 >> rate;
 rate = 1 + rate/100;
 int idx;//root的下标
 for (int i = 0; i < n; i++){
  int input;
  cin >> input;
  shops[i].parent = input;
  shops[input].sons.push_back(i);
  if (-1 == input)idx = i;
 }
 calcLevel(idx,0);
 int max_count = 0;
 int max = -1;
 for (int i = 0; i < n; i++){
  if (shops[i].level > max){
   max = shops[i].level;
   max_count = 1;
  }
  else if (shops[i].level == max){
   max_count++;
  }
 }
 double result_price = price0;
 for (int i = 0; i < max; i++){
  result_price *= rate;
 }
 printf("%.2f %d", result_price, max_count);
 return 0;
}


截图:
1090. Highest Price in Supply Chain (25)_第1张图片
——Apie陈小旭

你可能感兴趣的:(1090. Highest Price in Supply Chain (25))