ACM-计算几何之Pick-up sticks——poj2653

Pick-up sticks

题目:http://poj.org/problem?id=2653

Description

Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan has noticed that the last thrown stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected.

ACM-计算几何之Pick-up sticks——poj2653_第1张图片

Input

Input consists of a number of cases. The data for each case start with 1 <= n <= 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints of one stick. The sticks are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed.


Output

For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown.

The picture to the right below illustrates the first case from input.


Sample Input

5
1 1 4 2
2 3 3 1
1 -2.0 8 4
1 4 8 2
3 3 6 -2.0
3
0 0 1 1
1 0 2 1
2 0 3 1
0

Sample Output
Top sticks: 2, 4, 5.
Top sticks: 1, 2, 3.

Hint

Huge input,scanf is recommended.


题意:按照顺序向地上扔棍子,寻找没有被覆盖过的棍子序号。

当然后面的会将前面的覆盖掉(如果相交)。

挨个输入木棍,从第一个开始判断,第一个是否与后面n-1个相交,相交则第一个不是最上面的棍,

2层循环,轻松过了600MS。。

后来想想,这道题应该可以用STL的set做,就是将最上面的棍子放在一个集合里,每输入一个新棍子,

都与集合内所有棍子判断相交,相交则集合内棍子剔除掉,最后将后输入的放到集合中。。

这段时间一直在搞一个DFS数独题和一道省赛模拟题,太忙。。set方法等以后在整理一下,顺便做了吧。


#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct Dian
{
    double x,y;
};
struct Line
{
    Dian a,b;
}line[100001];
bool vis[100001];

double Min(double a,double b)
{
    return a>b?b:a;
}
double Max(double a,double b)
{
    return a>b?a:b;
}

double chaji(Dian p1,Dian p2,Dian p0)
{
    return (p1.x-p0.x)*(p2.y-p0.y)-(p1.y-p0.y)*(p2.x-p0.x);
}

bool across(Line m,Line n)
{
    if( Min(m.a.x,m.b.x)<=Max(n.a.x,n.b.x) &&
       Min(n.a.x,n.b.x)<=Max(m.a.x,m.b.x) &&
       Min(m.a.y,m.b.y)<=Max(n.a.y,n.b.y) &&
       Min(n.a.y,n.b.y)<=Max(m.a.y,m.b.y) &&
       chaji(m.a,n.b,n.a)*chaji(m.b,n.b,n.a)<0 &&
       chaji(n.a,m.b,m.a)*chaji(n.b,m.b,m.a)<0)
        return 1;
    else    return 0;
}



int main()
{
    int n,i,j;
    while(scanf("%d",&n)!=EOF)
    {
        if(!n)  break;
        for(i=0;i<n;++i)
            scanf("%lf%lf%lf%lf",&line[i].a.x,&line[i].a.y,&line[i].b.x,&line[i].b.y);
        memset(vis,0,sizeof(vis));

        for(i=0;i<n;++i)
        {
            if(vis[i])  continue;
            for(j=i+1;j<n;++j)
            {
                if(across(line[i],line[j]))
                {
                    vis[i]=1;
                    break;
                }
            }
        }

        bool flag=0;
        printf("Top sticks:");
        for(i=0;i<n;++i)
        {
            if(!vis[i])
            {
                if(!flag)   {printf(" %d",i+1);flag=1;}
                else    printf(", %d",i+1);
            }
        }
        printf(".\n");
    }
    return 0;
}


你可能感兴趣的:(ACM,计算几何,Sticks,Pick-up,poj2653)