Wooden Sticks
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output
2
1
3
先排序,如果长度相等,则重量从小到大排;否则,长度从小到大排。
然后选择第一个没有用过的木头依次向后找,用掉所有可以用的木头,然后返回第一个没有用过的木头继续找。
AC代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std; struct stick { int l,w; //l为长度,w为重量
}a[5005]; bool cmp(stick a1,stick a2) { if(a1.l==a2.l) return a1.w<a2.w; //长度相等,重量按从小到大排序
else return a1.l<a2.l; //长度不等,则长度按从小到大排序
} int main() { int T,n,i,p,j,vis[5005],flag,count;
scanf("%d",&T); while(T--) {
scanf("%d",&n);
memset(vis,0,sizeof(vis)); //设置标记,标记是否访问过这组数据
for(i=0;i<n;i++)
scanf("%d%d",&a[i].l,&a[i].w);
sort(a,a+n,cmp);
vis[0]=1; //先访问第一组
p=0; //记录第一个没有用过的木头
count=0; //记录次数
while(p!=n) {
count++; for(i=p+1,j=p,flag=1;i<n;i++) { if(vis[i]) //已访问,则访问下一组数据
continue; if(a[i].l>=a[j].l&&a[i].w>=a[j].w) //不用重新设置
{
vis[i]=1; //标记已访问
j=i; //更新要比较的数据
} else { if(flag) {
p=i; //只记录第一个没有用的木头
flag=0; } } } if(flag) //都用过了
break; }
printf("%d\n",count); } return 0; }