Printer Queue(打印队列)POJ3125

Printer Queue
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2817   Accepted: 1523

Description

Printer Queue(打印队列)POJ3125_第1张图片The only printer in the computer science students' union is experiencing an extremely heavy workload. Sometimes there are a hundred jobs in the printer queue and you may have to wait for hours to get a single page of output. 

Because some jobs are more important than others, the Hacker General has invented and implemented a simple priority system for the print job queue. Now, each job is assigned a priority between 1 and 9 (with 9 being the highest priority, 
and 1 being the lowest), and the printer operates as follows.
  • The first job J in queue is taken from the queue.
  • If there is some job in the queue with a higher priority than job J, thenmove J to the end of the queue without printing it.
  • Otherwise, print job J (and do not put it back in the queue).
In this way, all those importantmuffin recipes that the Hacker General is printing get printed very quickly. Of course, those annoying term papers that others are printing may have to wait for quite some time to get printed, but that's life. 

Your problem with the new policy is that it has become quite tricky to determine when your print job will actually be completed. You decide to write a program to figure this out. The program will be given the current queue (as a list of priorities) as well as the position of your job in the queue, and must then calculate how long it will take until your job is printed, assuming that no additional jobs will be added to the queue. To simplifymatters, we assume that printing a job always takes exactly one minute, and that adding and removing jobs from the queue is instantaneous.

Input

One line with a positive integer: the number of test cases (at most 100). Then for each test case:
  • One line with two integers n and m, where n is the number of jobs in the queue (1 ≤ n ≤ 100) and m is the position of your job (0 ≤ m ≤ n −1). The first position in the queue is number 0, the second is number 1, and so on.
  • One linewith n integers in the range 1 to 9, giving the priorities of the jobs in the queue. The first integer gives the priority of the first job, the second integer the priority of the second job, and so on.

Output

For each test case, print one line with a single integer; the number of minutes until your job is completely printed, assuming that no additional print jobs will arrive.

Sample Input

3

1 0
5
4 2
1 2 3 4
6 0
1 1 9 1 1 1

Sample Output

1

2

5

Source

Northwestern Europe 2006


题意: 一个打印序列,有优先级别顺序。从前往后扫描,若该作业优先级别已是最高,则执行此作业。若不是,放到队列末尾。 求指定位置的作业W被执行的时间。

思路: 模拟算法,采用queue数据结构,先执行所有比作业W优先级高的作业,当然也要按照优先级从高到低顺序执行。然后,从队列首开始扫描,①优先级同W一样的不同作业,pop();count++。②优先级小于W的作业,直接pop()。③指定作业W,停止扫描,pop()队列剩余元素。

代码如下:

#include <iostream>
#include <queue>
using namespace std;

struct jobNode
{
	int pos;
	int pri;
};

queue <jobNode> q;
int p[10];


int getNext(int pos)
{
	for(int i=pos;i>0;i--)
	{
		if(p[i])return i;
	}
	return 0;
}

int main()
{
	int t,n,m;
	int job[100];
	
	int i,j,max,count;
	jobNode jn;

	freopen("in.txt","r",stdin);
	cin>>t;
	for(i=0;i<t;i++)
	{
		memset(job,0,sizeof(int)*100);
		memset(p,0,sizeof(int)*10);
		cin>>n>>m;
		count=1;
		for(j=0;j<n;j++)
		{
			cin>>job[j];
			p[job[j]]++;
			
			jn.pos=j;
			jn.pri=job[j];

			q.push(jn);
		}
		max = getNext(9);
		while(job[m]<max)
		{
			while(q.front().pri<max)
			{q.push(q.front());q.pop();}
			count++;
			q.pop();
			p[max]--;
			max = getNext(max);
		}
		while(q.front().pos!=m)
		{
			if(q.front().pri==job[m])count++;
			q.pop();
		}
		while(!q.empty())q.pop();   //注意!不要忘记!
		cout<<count<<endl;
	}
	return 0;
}



你可能感兴趣的:(Printer Queue(打印队列)POJ3125)