HDU 3501 alculation 2 【欧拉函数】

Calculation 2

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2379    Accepted Submission(s): 1003


Problem Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
 

Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
 

Output
For each test case, you should print the sum module 1000000007 in a line.
 

Sample Input
   
   
   
   
3 4 0
 

Sample Output
   
   
   
   
0 2
/*
题目大意:求所有小于N且与N为非互质数的和


小于N且与N互质的数的和 = 小于N的数的和 - 小于N且与N为互质数的和 


求所有小于N且与N为互质数的和 
1.欧拉函数可求与N互质的数的个数
2.若已知m与n互质,则n-m也与n互质 
*/
欧拉函数证明: 
http://hi.baidu.com/ldante/item/28042208e1f139133b53eefc 
#include<cstdio>
#define mod 1000000007
__int64 eular(__int64 n)//欧拉函数模板 
{
    __int64 ret=1;
    for(__int64 i=2; i*i<=n; i++)
    {
        if(n%i==0)
        {
            n/=i; ret*=i-1;
            while(n%i==0)
            {
                n/=i; ret*=i;
            }
        }
    }
    if(n>1) return ret*=n-1;
    return ret;
}
int main()
{
    __int64 ans,n;
    while(scanf("%I64d",&n)&&n)
    {
        ans=n*(n-1)/2;
        printf("%I64d\n",(ans-n*eular(n)/2)%mod);
    }
    return 0;
}







你可能感兴趣的:(HDU)