hdu 1005Number Sequence 看高手如何找规律

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 63052    Accepted Submission(s): 14475


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
   
   
   
   
1 1 3 1 2 10 0 0 0
 

Sample Output
   
   
   
   
2 5
 

Author
CHEN, Shunbao
 

Source
ZJCPC2004
 

Recommend
JGShining
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
题意: 输入 A,B,n 求f(n)


思路:
很容易想到有规律 打表也能看出有规律 但是对于每组 A B 规律却不一样 循环节不同
我一开始是找的从第一个数据开始的循环节 但是循环节不一定从第一个位置开始 所以我的毫无疑问会错
下面是大牛的代码    很有意义
参考地址:

滨州研究中心

http://www.bzghou.com/2012/8/7/00458.html

#include<iostream>
#include<stdio.h>
using namespace std;
int f[100000005];
int main()
{
    int a,b,n,i,j;

    f[1]=1;f[2]=1;
    while(scanf("%d%d%d",&a,&b,&n))
    {
        int s=0;//记录周期
        if(a==0&&b==0&&n==0) break;
        for(i=3;i<=n;i++)
        {
            f[i]=(a*f[i-1]+b*f[i-2])%7;
            for(j=2;j<i;j++)
            if(f[i-1]==f[j-1]&&f[i]==f[j])//此题可以这样做的原因就是 2个确定后就可以决定后面的
            {
                s=i-j;
                //cout<<j<<" "<<s<<" >>"<<i<<endl;
                break;
            }
            if(s>0) break;
        }
        if(s>0){

                 f[n]=f[(n-j)%s+j];
                 //cout<<"f["<<n<<"]:="<<"f["<<(n-j)%s+j<<"] "<<endl;
               }
        cout<<f[n]<<endl;

    }
    return 0;
}

第二种方法

因为f[i]只能取0~7,下面的程序用m[x][y],记录f[i]的值x y相邻时候出现过。

鸽巢原理知,状态总数不会超过7*7
View Code

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

const int N = 100;
int f[N], m[8][8];

int main()
{
    int n, a, b, k, x, y;
    while (scanf("%d%d%d", &a, &b, &n) != EOF && a+b+n)
    {
        memset(m, 0, sizeof(m));
        f[1] = f[2] = x = y = 1;
        k = 3;
        while (!m[x][y])
        {
            m[x][y] = k;
            cout<<"m["<<x<<"]"<<"["<<y<<"]="<<k<<endl;
            f[k] = y = (a * y + b * x) % 7;
            x = f[k-1];
            k++;
        }
        int h = m[x][y];cout<<h<<" "<<k-h<<endl;
        if (n < k)
            printf("%d\n", f[n]);
        else printf("%d\n", f[(n-h)%(k-h)+h]);
    }
}





你可能感兴趣的:(input,each,Signal,output)