uva 152 - Tree's a Crowd

 Tree's a Crowd 

Dr William Larch, noted plant psychologist and inventor of the phrase ``Think like a tree--Think Fig'' has invented a new classification system for trees. This is a complicated system involving a series of measurements which are then combined to produce three numbers (in the range [0, 255]) for any given tree. Thus each tree can be thought of as occupying a point in a 3-dimensional space. Because of the nature of the process, measurements for a large sample of trees are likely to be spread fairly uniformly throughout the whole of the available space. However Dr Larch is convinced that there are relationships to be found between close neighbours in this space. To test this hypothesis, he needs a histogram of the numbers of trees that have closest neighbours that lie within certain distance ranges.

Write a program that will read in the parameters of up to 5000 trees and determine how many of them have closest neighbours that are less than 1 unit away, how many with closest neighbours 1 or more but less than 2 units away, and so on up to those with closest neighbours 9 or more but less than 10 units away. Thus if is the distance between the i'th point and its nearest neighbour(s) and , with j and k integers and k = j+1, then this point (tree) will contribute 1 to the j'th bin in the histogram (counting from zero). For example, if there were only two points 1.414 units apart, then the histogram would be 0, 2, 0, 0, 0, 0, 0, 0, 0, 0.

Input and Output

Input will consist of a series of lines, each line consisting of 3 numbers in the range [0, 255]. The file will be terminated by a line consisting of three zeroes.

Output will consist of a single line containing the 10 numbers representing the desired counts, each number right justified in a field of width 4.

Sample input

10 10 0
10 10 0
10 10 1
10 10 3
10 10 6
10 10 10
10 10 15
10 10 21
10 10 28
10 10 36
10 10 45
0 0 0

Sample output

   2   1   1   1   1   1   1   1   1   1

给出一组三维点坐标统计他们之间最短距离在[0,1),[1,2)......[9,10)范围内的个数。

用了long类型runtime error好几次坑啊。一直以为int是-32768-32767被以前Pascal的Integer误导了

整型 [signed]int -2147483648~+2147483648

无符号整型unsigned[int] 0~4294967295

短整型 short [int] -32768~32768

无符号短整型unsigned short[int] 0~65535

长整型 Long int -2147483648~+2147483648

无符号长整型unsigned [int] 0~4294967295

字符型[signed] char -128~+127

无符号字符型 unsigned char 0~255

单精度 float 3.4 x 10^(-38)~ 3.4 x 10^(+38)

双精度double 1.7 x 10^(-308)~ 1.7 x 10^(+308)

长双精度 long double 1.7 x 10^(-308)~ 1.7 x 10^(+308)

#include <stdio.h>
#include <math.h>
void main()
{int a[10],num=1,i,j,min,k;
 double x[5010],y[5010],z[5010];
 while (scanf("%lf%lf%lf",&x[num],&y[num],&z[num]))
 if (x[num]+y[num]+z[num]==0) break;
                         else ++num;
 for (i=0;i<10;i++) a[i]=0;
 for (i=1;i<num;i++)
 {min=11;
  for (j=1;j<num;j++)
  {if (i!=j)
  {k=sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j])+(z[i]-z[j])*(z[i]-z[j]));
   if (k<min) min=k;
  }
  }
  if (min<10)
  ++a[min];
 }
 for (i=0;i<10;i++)
 printf("%4d",a[i]);
 printf("\n");
}

你可能感兴趣的:(uva 152 - Tree's a Crowd)