Farm Irrigation
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4408 Accepted Submission(s): 1911
Problem Description
Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.
Figure 1
Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map
ADC
FJK
IHE
then the water pipes are distributed like
Figure 2
Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.
Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?
Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.
Input
There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.
Output
For each test case, output in one line the least number of wellsprings needed.
Sample Input
2 2
DK
HF
3 3
ADC
FJK
IHE
-1 -1
Sample Output
题目大意:
给你一张n*n图,每个点可以连接左上右下,可以详见上面的A~K十一幅图,然后每个点可以选择这十一幅其中的任意一张。问你有多少的联通分支。
解题思路:每张图用四个坐标表示能否向左上右下四个方向延伸,然后就是并查集判断了。
题目地址:Farm Irrigation
AC代码:
#include<iostream>
#include<cstdio>
using namespace std;
char map1[52][52];
int r[3000],sum,n,m;
//左上右下
int ch[12][4]={1,1,0,0,0,1,1,0,1,0,0,1,0,0,1,1,0,1,0,1,1,0,1,0,1,1,1,0,1,1,0,1,1,0,1,1,0,1,1,1,1,1,1,1};
int find1(int x)
{
while (r[x]!=x)
x=r[x];
return x;
}
void merge1(int x,int y)
{
x=find1(x);
y=find1(y);
if(x!=y)
sum--;
r[x]=y;
}
void uni(int i,int j)
{
if (j>0 && ch[map1[i][j]-'A'][0] && ch[map1[i][j-1]-'A'][2])
merge1(i*m+j-1,i*m+j); //能否与左边的相连
if (i>0 && ch[map1[i][j]-'A'][1] && ch[map1[i-1][j]-'A'][3])
merge1((i-1)*m+j,i*m+j); //能否与上边的相连
}
int main ()
{
int i,j;
while (cin>>n>>m)
{
if (n==-1 && m==-1)
break;
for(i=0;i<3000;i++)
r[i]=i;
sum=n*m;
for(i=0;i<n;i++)
cin>>map1[i];
for (i=0;i<n;i++)
for (j=0;j<m;j++)
uni(i,j);
printf("%d\n",sum);
}
return 0;
}
/*
2 2
DK
HF
3 3
ADC
FJK
IHE
-1 -1
*/
//15MS 296K