题目1184:二叉树遍历

题目描述:

编一个程序,读入用户输入的一串先序遍历字符串,根据此字符串建立一个二叉树(以指针方式存储)。
例如如下的先序遍历字符串:
ABC##DE#G##F###
其中“#”表示的是空格,空格字符代表空树。建立起此二叉树以后,再对二叉树进行中序遍历,输出遍历结果。

输入:

输入包括1行字符串,长度不超过100。

输出:

可能有多组测试数据,对于每组数据,
输出将输入字符串建立二叉树后中序遍历的序列,每个字符后面都有一个空格。
每个输出结果占一行。

样例输入:
abc##de#g##f###
样例输出:
c b e g d f a 
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <vector>
#include <cstring>
#include <algorithm>
using namespace std;

struct Node{
	char ch;
	Node *left,*right;
};
char s[101];
void build(Node *&root,int &index,int n){
	if(index == n)
		return;
	if(s[index] == '#'){
		root = NULL;
		index++;
	}
	else{
		root = new Node;
		root->ch = s[index];
		index++;
		build(root->left,index,n);
		build(root->right,index,n);
	}
}

void print(Node *root){
	if(root != NULL){
		print(root->left);
		cout << root->ch << " ";
		print(root->right);
	}
}

int main()
{
	while(cin >> s){
		Node *root = NULL;
		int len = strlen(s);
		int index = 0;
		build(root,index,len);
		print(root);
		cout << endl;
	}
	return 1;
}


你可能感兴趣的:(题目1184:二叉树遍历)